Forum Settings
       
« Previous 0 Next »
Reply To Thread

Unable to connect to updaterFollow

#1 Sep 26 2010 at 9:36 PM Rating: Decent
Every attempt I have made to connect to the updater (going on 9 hours of trying now) fails and or times out. I have disabled my AV, Windows Firewall, Router Firewall and still no dice. The odd part is my internet connection icon dies when I try to run the updater, but I have no issues surfing other sites, downloading driver updates, etc.

I tried the Megaupload link provided in a different post and the site told me I exceeded my download limit (first time every DL'ing from megaupload) and I refuse to pay for a premium account for a file the I have already paid $80 to obtain from SE.

Any ideas?

I played FFXI for 4 years and have been looking forward to FFXIV for quite some time, only to have my entire day off wasted without even getting to see the game in action. I find it very funny that their payment system works correctly, but they could care less about the rest of the product as long as they get your money. Ugg, why make it this difficult...

Router is a WNDR3300
Win Vista 32 bit (running the update in admin mode)
4 GB ram
GT8800 vid card (next on the list for upgrading) current drivers were updated this morning
« Previous 0 Next »
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 174 All times are in CST
Luceo, Theonehio, Anonymous Guests (172)