Forum Settings
       
This Forum is Read Only

game boot upFollow

#1 Sep 01 2010 at 8:22 PM Rating: Default
*
148 posts
the loader to go to the login to eneter the game is also down lol
____________________________
Dont Hate The Player Hate The Game.

Lord Braska
Melmond server
#2 Sep 01 2010 at 8:23 PM Rating: Decent
Scholar
43 posts
Yep, even with a beta key you don't get to play! HARHAR
#3 Sep 01 2010 at 8:28 PM Rating: Default
*
148 posts
account page to register is down as well seems like all there servers r way to congested i got 1 of 2 keys i need lol and by the way the keys are emailed
____________________________
Dont Hate The Player Hate The Game.

Lord Braska
Melmond server
#4 Sep 01 2010 at 8:31 PM Rating: Decent
6 posts
I have not gotten an email... was it sent to your square enix account or the emial registered to the account?
#5 Sep 01 2010 at 8:34 PM Rating: Default
*
148 posts
well u need to login with ur se account and accept terms i did that and hit submit and then a few secs later i got a key in my email but the next page was not ablt to be displayed so im not sure if it was on screen or not. when i went to register it i hit next n that went down so i have no idea if it went through or not and the game boot up isnt workin glol
____________________________
Dont Hate The Player Hate The Game.

Lord Braska
Melmond server
#6 Sep 01 2010 at 8:38 PM Rating: Decent
6 posts
lol well been tryin to log into se account cant get to the page this is crazzzzzy!
#7 Sep 01 2010 at 8:47 PM Rating: Decent
Scholar
*
135 posts
got it \o/ Hail internet
#8 Sep 01 2010 at 8:48 PM Rating: Decent
Scholar
***
1,497 posts
Mmmm, Irony, tastes so good.
This forum is read only
This Forum is Read Only!
Recent Visitors: 13 All times are in CST
Anonymous Guests (13)