Forum Settings
This Forum is Read Only

Can't log in to FF XIV Beta Test SiteFollow

#1 Sep 02 2010 at 3:42 AM Rating: Decent
1 post
I've been trying to log in with my account which has a beta key linked to it, first it asks you the following:

The FINAL FANTASY XIV Beta Test Site can only be accessed by those who have been granted Beta Test accounts.

Beta testers can log in from the link below using their Square Enix Account.

I click the link, it takes me to the login page, I log in, and it sends me back to the beta test site with the following:

Login process is running.
If you change the screen, please press the NEXT button.

Which lasts for about 5 seconds and then just vanishes and it prompts me to log in using the first link again.

I read it had to do with browsers so I tried IE, Chrome and Firefox numerous times, none of which worked. Any help?
#2 Sep 03 2010 at 3:39 AM Rating: Decent
1 post
I had the same problem. Just try the beta site from the region you are from. For example: if North American, if European, etc.

Worked for me.
This forum is read only
This Forum is Read Only!
Recent Visitors: 19 All times are in CDT
Anonymous Guests (19)