Forum Settings
       
This Forum is Read Only

equipping with macros - help.Follow

#1 Sep 03 2010 at 8:38 AM Rating: Decent
13 posts
I want to start learning how to write macros but for some reason none of the commands i'm using work.

/equip main Weathered Fishing Rod
/equip head Weathered Beach Hat

none of the equip lines work for me.

Please help,
Thanks in advance
#2 Sep 03 2010 at 8:40 AM Rating: Decent
Scholar
*
59 posts
Put item names with multiple words in quotes
#3 Sep 03 2010 at 9:07 AM Rating: Good
***
2,815 posts
Actually i think it's bugged because i spend a good 15 minutes trying to get my body equip line working. Tried with every combination of quotes, no quotes, caps, no caps... still wont work.
____________________________
Minecraft : My anti-MMO
Terraria : My anti-Minecraft
#4 Sep 03 2010 at 9:12 AM Rating: Decent
Scholar
***
1,536 posts
its not bugged it works, make sure you have quotes around the name...

on this subject, how do i macro in off hand weapon?

/equip off "" doesn't work...
____________________________
MUTED
#5 Sep 03 2010 at 9:26 AM Rating: Good
Scholar
***
1,202 posts
Macros work this way.

/equip main "Weathered Gladius" (Would equip a sword in the main hand)
/equip sub "Square Maple Shield" (Would equip a shield in off hand)
/equip body "Canvas Robe" (Would equip to the body armor slot)

Actions work this way
/equipaction 2 "Fire" (Would equip the spell fire to the 2nd action slot)
/equipaction 3 "Blizzard" (Would equip the spell blizzard to the 3rd action slot)

For actions it's a sequential number 1 - 30 1 being the 1st slot always taken by your default ability 10 being slot 0 on your action bar, 11 would be the 1st slot position on your second action bar, and 21 would be the 1st slot on your 3rd action bar. Visual representation is like this
1 2 3 4 5 6 7 8 9 10
11 12 13 14 15 16 17 18 19 20
21 22 23 24 25 26 27 28 29 30

To equip actions learned traits it works the same way. For Botanist or Miner that get Lucky Strike, or other special traits you would still use /equip action 1 "Lucky Strike" the game will knowthat Lucky Strike needs to go to your gathering and synthesis bar and not your action bar.

Oh and don't copy and paste a macro command from a forum into your game console, I know a few friends who did it this way, and could not get there macro to work. Also to fire your macro you must hit CTRL/ALT + # it's not CTRL/ALT + Enter Key

Edited, Sep 3rd 2010 9:27am by Technolust
#6 Sep 03 2010 at 9:30 AM Rating: Decent
13 posts
yeah, i used quotes and now it works perfectly.

I absolutely love this macro stuff.
This forum is read only
This Forum is Read Only!
Recent Visitors: 22 All times are in CST
Anonymous Guests (22)