Forum Settings
       
This Forum is Read Only

Still having problems on the beta site.Follow

#1 Sep 05 2010 at 3:58 PM Rating: Decent
32 posts
Is there anything else I can do to try and get through the website? I've tried changing my password, lowering my security settings, also tried the EU site. Same thing happens every time. Press Final Fantasy XIV Beta Site Login, put in my info, goes to the page with the next button, sometimes i press it sometimes I don't. Either way I promptly get sent back to the Site Login page. What am I doing wrong?! ;(
#2 Sep 05 2010 at 4:01 PM Rating: Good
***
2,010 posts
I don't think that you are doing anything wrong to be honest. I can't get in either, since the whole key switchover nonsense. I can get into my SE account, confirm that I do in fact have the beta registered (I even went so far as to try to apply again only to be denied because I am allegedly in the beta), but I cannot get into the website anymore. Apparently, they are no longer interested in my opinion.

:p
This forum is read only
This Forum is Read Only!
Recent Visitors: 24 All times are in CST
Anonymous Guests (24)