Forum Settings
       
This Forum is Read Only

DirectX ErrorFollow

#1 Sep 05 2010 at 4:06 PM Rating: Decent
2 posts
I keep getting this error when I launch the game, "Unable to detect DirectX device. The program has shutdown. Please restart Final Fantasy XIV.". My DirectX is up to date. Someone help?
#2 Sep 05 2010 at 4:23 PM Rating: Good
**
749 posts
What video card do you have?
Have you updated your GFX drivers?

The absolute ONLY advice I can give you is to try turning down AA a notch, and making sure depth of field is disabled.
As a last ditch effort, if all the above fails, you can try uninstalling all graphics card drivers/software, run driver sweeper to completely remove all vestiges of drivers, and reinstall.
____________________________
http://www.rantmedia.ca/newsreal/
http://www.piratepartyradio.com


The Truth is a virus
#3 Sep 05 2010 at 6:48 PM Rating: Decent
3 posts
I also get this, I'm using a nvidia 9800GT, i cant make it past the city intros without crashing :(.
#4 Sep 05 2010 at 6:57 PM Rating: Good
Avatar
***
1,416 posts
Funderberry wrote:
I keep getting this error when I launch the game, "Unable to detect DirectX device. The program has shutdown. Please restart Final Fantasy XIV.". My DirectX is up to date. Someone help?


Go Here and downlaod DirectX 9. DirectX 11 does not mean you are up to date, just that you have the latest version. However, FF XIV uses DirectX 9.0c, not DirectX 11.
____________________________

#5 Nov 03 2010 at 8:32 AM Rating: Decent
1 post
I am having the same problem with this. If (and that is a big if) I get to the title screen, I can run the opening movie a million times, but once I start up the game... the program stops running. Are you saying this is all a Direct X issue?
Necro Warning: This post occurred more than thirty days after the prior, and may be a necropost.
#6 Nov 04 2010 at 12:16 AM Rating: Decent
Scholar
Avatar
*
165 posts
I had this problem until I downloaded and installed the most recent drivers (in my case, for nvidia), it was the version 260, and it fixed any problems for me, Also, go to nvdia control panel, and in the 3d settings you can pick ffxiv to automatic adjust the setting for it.
____________________________
"Make something idiot proof... someone will create a better idiot"
#7 Jun 15 2013 at 5:13 PM Rating: Decent
1 post
When I start up my beta i hit play and it says "Fatal Error Direct X .(10000000)" or something along that, i Googled the error and got absolutely nothing
Necro Warning: This post occurred more than thirty days after the prior, and may be a necropost.
#8 Jun 15 2013 at 5:24 PM Rating: Excellent
Anterograde Amnesia
Avatar
*****
12,363 posts
Click start and type "dxdiag" without the quotes, run that. Any errors?
____________________________
"Choosy MMO's choose Wint." - Louiscool
The greatest trick the devil ever pulled was to convince the world he didn't exist.
Keyser Soze - Ultros
Guide to Setting Up Mumble on a Raspberry Pi
#9 Jul 14 2013 at 8:12 PM Rating: Decent
4 posts
Im not good for english be simple ok?
what i do if i have this problem?

I have DirectX 11 [some people say with i need download directX 9 but directX11 can work with DirectX 9, DirectX 11 have all before versions]
403 GB free of 465
Windows 7 Ultimate 32 bits [service pack 1]
Intel(R) Atom (TM) CPU D410 @1.66 GHz
This forum is read only
This Forum is Read Only!
Recent Visitors: 16 All times are in CST
Anonymous Guests (16)