Forum Settings
       
This Forum is Read Only

PS2 Gamepad IssueFollow

#1 Sep 05 2010 at 11:49 PM Rating: Decent
Scholar
*
135 posts
Since the servers are down, I figured I'd fiddle around setting up a gamepad. Mostly just to see how much worse it is for controls (To me of course, to each his own), compared to a properly designed keyboard/mouse system.

But anyways, I use a 4 port PS2 Controller to USB Adapter. All the buttons and sticks work in the windows settings applet for joysticks and such. The FFXIV Config even see's the adapter, but I cannot set any controls. As soon as I choose to use the gamepad, it puts Axis 25/- in the top box for Target/Open Menu, then doesn't allow me to set anything else.

It's honestly bothering me more that I can't figure out why it's not working over not not being able to use it.
#2 Sep 07 2010 at 5:16 PM Rating: Decent
5 posts
I just went ahead and bought one from Best buy for 25 bucks. Works like a charm.
#3 Sep 07 2010 at 5:23 PM Rating: Good
Sage
*
182 posts
I had the same issue until i downloaded Motionjoy. once i installed the program it runs smooth now
____________________________
#4 Sep 07 2010 at 5:45 PM Rating: Decent
Scholar
**
440 posts
I have this same issue and I am using 32 bit Vista. How I fix it is you go into Control panel > Game Controllers > select one of the "4 axis 16 bit joystick" > click properties. That's it. OH! And you need to have this open THE ENTIRE TIME YOU ARE PLAYING THE GAME! If you don't, as soon as you start the program it will crash.

It's really not that big of a pain since you can create a shortcut to the Gamepad Controllers onto your desktop. Hope this helps!
#5 Sep 07 2010 at 6:04 PM Rating: Decent
Scholar
*
135 posts
Actually, it turns out this PS2 to USB Adapter doesn't use xinput, only DirectInput. FFXIV uses xinput. So I grabbed the xbox360 controller emulator to create a virtual 360 controller and everything maps fine.
#6 Sep 07 2010 at 6:14 PM Rating: Decent
Scholar
*
135 posts
jtully wrote:
I had the same issue until i downloaded Motionjoy. once i installed the program it runs smooth now


This is the solution for PS3 controllers. Doesn't help that MotionJoy doesn't see my PS2 controllers anyhow.

And I had no plans to buy another for this game, this is only to goof around with. I'd never play seriously without the mouse/keyboard. The level of control just isn't there.
#7 Sep 13 2010 at 7:03 PM Rating: Decent
1 post
Hi Ispanolfw,

have the same controller as you but didn't figure out how to make it with the 360 controller emulator. Did you put the xinput.dll thing in the game directory?
#8 Sep 14 2010 at 9:51 PM Rating: Decent
3 posts
Hey there, I also am using a Super Joy Box Pro 3. I have set up the Xinput.ini and the XinputTest application works perfectly! However, I still can't get the FFXIV Gamepad Config to work. As the above user has done, my xinput DLL and .ini are both in the FFXIV executables' directory. Can you please, please, please give us some instruction as to how this can be fixed? What did you do differently? Thank you so much!
#9 Sep 14 2010 at 10:26 PM Rating: Good
Scholar
*
178 posts
Axis 25/- is one of the analog triggers, try holding them up as they could be pressed down a bit, or try calibrating them in the windows gamepad control panel.

I have had this problem but I just set the triggers to digital in motioninjoy.
#10 Sep 15 2010 at 12:58 AM Rating: Decent
3 posts
Heya, I appreciate the response, but I believe motioninjoy is for PS3 DS3 users, which probably wouldn't help too much in our case. Also, the controller was calibrated just fine and worked properly in the said testing application above, but thanks for the axis insight.

However, I've found a fix for the problem. I was using an older (different?) app than ispanolfw which was, for some reason, more commonplace in my search results. To the other poster above, try this:

http://code.google.com/p/x360ce/downloads/list

Just put the executable into the FFXIV root executable folder and run it. It will create a .ini for saving your settings and the .dll needed for the app and the game to interface.

Snag #1: If the app isn't working or complains about mscvr.dll or something or other, download the x86 2010 C++ redistributable from Microsoft if you run 32-bit Windows. If you run 64-bit, download and install both the x86 and x64 packages. Also, go ahead and download the June 2010 Directx Run-times, just to be safe. Once I did these three things (took ~three minutes tops), the app worked fine.

Snag #2: In my case of Super Joy Box 3, turning off "Native Mode" in the advanced options allowed me to start configuring buttons.

Once you map out all of your buttons and axes to the Xbox controller's respective buttons and axes in the emulator, leave it open and run the FFXIV config program. You should now be able to select your gamepad from the drop-down menu and set the buttons and axes accordingly. Bear in mind, since this is emulating the Xinput driver used for Xbox controllers, the button layouts and names for the axes will be different than what they are for your actual controller. For instance, the L2/R2 buttons may be buttons 5 and 6 according to your gamepad, but according to the emulated gamepad, where these are triggers, they will be labeled as "axes". Don't worry about that.

Now that you're configured for using emulated Xinput with FFXIV, just load the game and enjoy. Simply remember to load the emulator prior to playing the game each time, and you're in business!

tl;dr
Download program, map buttons. Leave app open, map emulated buttons in FFXIV config. Always have app open when playing FFXIV.

The great thing about this fix is it serves for ANY controller that doesn't support Xinput, not just this particular adapter.

Best Wishes!
#11 Sep 15 2010 at 1:57 AM Rating: Good
*
59 posts
http://www.mediafire.com/?ksnwnlzw6svs1vr

Since you use a Super Joy Box 3 Pro like I do, you could use my config.pad file which I manually edited.

Place it in the folder below, replacing the existing file:

\..\My Games\FINAL FANTASY XIV Beta Version\

I have the buttons mapped as follows:
Triangle	Emote List / Stack Battle Commands 
Circle		Passive / Active Mode 
X		Select / Confirm 
Square		Cancel 
L2		Open Macros (Ctrl) 
R2		Open Macros (Alt) 
L1		View Status Effects 
R1		Target Lock 
Start		Main Menu 
Select		Display Map 
L3		Auto-Run 
R3		Change View


In the Super Joy Box 3 Pro driver, you must set Direction Button Mode to 'Button' and Controller Mode to 'Analog' for my config.pad to work properly. Ignore the Axis/-25, my config.pad has D-PAD UP mapped correctly, but make sure to never re-save the file in FFXIV gamepad config or that setting will once again be lost.

Simple as that. Works perfectly in-game, even vibration.
This forum is read only
This Forum is Read Only!
Recent Visitors: 19 All times are in CST
Anonymous Guests (19)