Forum Settings
This Forum is Read Only

update error 20524Follow

#1 Sep 11 2010 at 6:13 PM Rating: Default
19 posts
got a boot update, D2010.09.10.2001.patch, i get to 100% download. then it install, but stop at 99.1% and says Error has occurred : error 20524... any ideas what could be causing this?
#2 Sep 11 2010 at 6:23 PM Rating: Decent
213 posts
hardware mouse or that windower addon, replace your "ffxigame.exe" with a backup then patch
#3 Sep 11 2010 at 6:34 PM Rating: Default
19 posts
how do i do that? dont recall using mouse hardware, or new windower...
#4 Sep 11 2010 at 7:03 PM Rating: Decent
213 posts
im sorry i assumed you did as this error happens after the mouse patch is applied, if your getting this error still i would try running FFXIV as a administrator, that might work.
#5 Sep 11 2010 at 8:06 PM Rating: Default
19 posts
tried running in administrator,still getting error, did any1 else have a boot update, thats the red screen right?
#6 Sep 11 2010 at 8:33 PM Rating: Default
160 posts
im geting the same problem and didnt edit the game at all and its ticking me off atm.
Server: Valefor
Character: Heya
Jobs: BLM 75, BLU 75, PLD 75 everything else at SJ cap
Retired: Febuary, 2008

Server: Ravencrest
Classs: Druid, Warlock, Mage, Death Knight 80
Retired: June, 2010

Server: Fabul
Name: Heya Yamamoto
Race: Lilifell Dunesfolk
Primary Class: conjur
#7 Sep 22 2010 at 6:17 PM Rating: Decent
256 posts
anyone getting this error with the retail version? I am and it won't go away. So far I haven't been able to find any real fixes for it.
*Retired :: August 2002 - December 2005*
Ragnarok Server
Linkshells: DigitalBackSpin, DBSDynamis, CKofVD
Goldsmith 85, Blacksmith 30
#8 Sep 22 2010 at 7:27 PM Rating: Decent
19 posts
Uninstall your game. Delete the folder directory that this program created.

Install a new copy. Now, DO NOT execute any file yet. Just run the game and let the patch do the work. You have to patch it 2 time with first patch at around 5.2MB and the 2nd patch 423MB.

I got this error and finally realize that default installation before patching, there wasn't any FFgame.exe in the folder. Which is correct. Say before you patch it, you execute FFconfig.exe, it will somehow create the FFGame.exe and is the reason why the patch wont work.

I solve it yesterday.
#9 Sep 22 2010 at 8:45 PM Rating: Good
2,204 posts
I am going to try and do what some people never do... I am going to actually use an existing thread to actually say that I am having the same problem and what I have done to try and remedy it... but it still won't work.

I am getting the same Update Error 20524 that others are getting. It happens during the second larger (450ish MB) patch, and I get to 100% on the patcher before it gives me the error.

I have tried using the torrent to download the patch file. I am able to do this fine because I did it on the open beta, but it still errors at 100% still. Yes, I have uninstalled the beta client and deleted its folders BEFORE installing the retail version.

I have searched with Google and found that some people have had it work if they move the ffxigame.exe file out of their main FFXIV folder, then use the ffxiboot.exe file to patch the game, and then move the fxigame.exe folder back to that folder.... But when I do that the ffxiboot.exe file creates a new ffxigame.exe file whne it patches and it still errors.

The other way people have found around this error is to uninstall the entire game and reinstall it, but it took me almost 7 hours to install it from the DVD earlier... for some odd reason it was installing EXTREMELY slow. I am not too keen on doing that again unless someone can tell me why it was going so slow. I would HATE to uninstall the game only to find out that the error still pops up.

So I have two questions. Any clue why the install (not the patch) was going so slow, and is there a workaround on this Update Error?

(since I asked in an existing thread that no one may look at... I'll give it 30min or so and if no one responds I'll make a new thread.)
#10 Sep 23 2010 at 5:57 AM Rating: Decent
11 posts
Change the game.ver and boot.ver files to the current version. Mine is 2010.09.19.0000. Worked like a charm. If your's crashes at 100%, chances are all the files have been updated properly.
#11 Sep 23 2010 at 10:51 AM Rating: Good
521 posts
TheWix wrote:
Change the game.ver and boot.ver files to the current version. Mine is 2010.09.19.0000. Worked like a charm. If your's crashes at 100%, chances are all the files have been updated properly.

I did this yesterday on game.ver and it worked great, BUT:

Does anyone know of a way to have the game check files? My install yesterday was slightly less clean than I would like. While I didn't get corrupted .CAB errors, I did get two messages during the initial install about the CRC of two files not matching the cab. The only option that let me proceed was to ignore. I'm assuming it ignored and installed the file, not ignored and SKIPPED? Would love if I could have the game run through everything to make sure.

Then I got the error while updating, and had to change the game version file to proceed. At this point I'm feeling generally :/ about the whole thing and really just want to make sure everything is kosher without having to reinstall since I will probably get the CRC errors again and I'm just not touching torrents.

I can play the game fine it seems, although I do have the regular crashes like most others.
#12 Jan 05 2011 at 9:08 AM Rating: Decent
1 post
I've changed the game.ver file and boot.ver file to 2010.09.19.0000 as you did and saved.

It crashed at 100% like you said and it gave me the same error. But what I do next?

If I launch the game again it will start updating and crash again at 100%. What to do now?
Necro Warning: This post occurred more than thirty days after the prior, and may be a necropost.
This forum is read only
This Forum is Read Only!
Recent Visitors: 25 All times are in CDT
Anonymous Guests (25)