Forum Settings
This Forum is Read Only

Server Maintenance Follow

#1 Sep 12 2010 at 11:36 AM Rating: Default
237 posts
Hi there everyone, does anyone know if the servers are down, or just are not working properly. Yesterday I finally got the beta all updated, got into game. But when I got to the point where I was trying to get my character to leave the one room in the Limsa opening the game just goes to a loading screen then eventually says something about server maintenance. Now I don't think it is my computer since it appears to run very smoothly, but does anyone have an idea if this is due to the servers or is there something I can do to fix it on my end.
#2 Sep 12 2010 at 11:40 AM Rating: Decent
52 posts
Go to I usually check it at the same time I load up FFXIV. Right now it looks like the worlds are down.
#3 Sep 12 2010 at 11:41 AM Rating: Good
494 posts
maintenence from 10 pacific to 2 pacific (1est to 3 est) i believe.
#4 Sep 12 2010 at 11:42 AM Rating: Decent
Azurymber wrote:
maintenence from 10 pacific to 2 noon pacific (1est to 3 est) i believe.

#5 Sep 12 2010 at 11:44 AM Rating: Good
237 posts
O boy now I feel really stupid, didn't even realize that page /facepalm. Well thank you for your quick response good to know I'm not missing anything.
#6 Sep 12 2010 at 12:03 PM Rating: Excellent
Mistress of Gardening
14,661 posts
You can check the server status on this site by clicking "Server Status" in the menu. It will update every 2 minutes, but requires a refresh.
This forum is read only
This Forum is Read Only!
Recent Visitors: 24 All times are in CDT
Anonymous Guests (24)