Forum Settings
       
« Previous 0 Next »
This Forum is Read Only

Spores for the Ceremony; Wtf Cliff. Solved.Follow

#1 Sep 13 2010 at 10:37 AM Rating: Default
4 posts
I tried traveling to the location mentioned, and their was a huge cliff in the way.

In case you are retarded at navigating like myself, I shall post this in hopes to solve your problem a little quicker than it took me to solve it on my own. Just before you come to the cliff their is a split. If your monitor sucks at showing contrast, then it is very easy to miss, because all rocks look the same no matter how close or far they are.

Going left takes you down, rather than up. That is how you get to the area for this quest.

I posted this because it took me an hour to figure it out, and I saw many people go up to the cliff and spend 5 minutes running into the cliff hoping to fall or some such.

It would have been nice if they added a sign or some indication on the map... like perhaps that beige line turning left.
« Previous 0 Next »
This forum is read only
This Forum is Read Only!
Recent Visitors: 20 All times are in CST
Anonymous Guests (20)