Forum Settings
       
This Forum is Read Only

Need some assistanceFollow

#1 Sep 22 2010 at 7:46 PM Rating: Decent
8 posts
Hi, I just registered here, and like many of you, I pre-ordered the collector's edition, and even shelled out the extra money to get it on the 22nd. I participated in the beta, and the benchmark ran perfectly, and my system specs met the recommended ones. So I felt pretty safe spending $80 on the game and release date shipping. I received my copy as expected, spent about an hour and a half, perhaps longer, installing and updating (also expected) while eagerly watching the development DVD. Updating finishes, and I wake up, start the launcher, login, click play... then it crashes. Final Fantasy XIV has stopped working. I follow troubleshooting on the S-E site which told me to lower graphics settings, update drivers, etc. I consider myself to be pretty knowledgeable when it comes to computers and software, and I knew right away that would not solve the problem. Lowered settings, drivers already up to date. Ran in compatibility, ran as administrator, still nothing. Fullscreen, windowed, nothing is working. I'm at my wits end and decide to call Square-Enix expecting to be on hold for quite a while. 2 hours later, and many "All our agents are occupied at the moment," I tell you that phrase has been engraved in my brain. The phone rings and is connecting to a customer service agent, 10 minutes before they close (which I was told), wow, what luck. The C.S. Rep asks me a ticket number, which I tell him I do not have. He tells me I need to generate one and I agree and continue to the site to make one, only to be interrupted by him saying that he doesn't want to wait 5 minutes for me to generate a ticket.. after I waited 2 hours to connect to him. Seriously, why would I go online and generate an e-mail support ticket when I can call? Anyways, at the current moment I'm re-installing and going to re-update again and see if that helps. It turns out that the 2 hours I thought I'd have spent installing quickly turned into 5 hours wasting my whole day and any hope of playing. I have classes and work tomorrow, meaning by time I get home they will yet again be closed and unable to help me.

Excuse my long, dramatic story of my day, had to vent... But has anyone else run into this problem? Has anyone solved it, if so, how? Specs as followed:

OS: Windows 7 Home Premium x64 6.1, build 7600
RAM: 4GB
HDD: 1.5TB
DirectX: 11
Processor: Intel i7 U640 @1.2GHz Quad-Core
GPU: NVIDIA GeForce GT 335M (1024MB Dedicated, 2714MB Total)
System Model: Alienware M11x R2

The only thing, and the only thing that I can think of that would keep me from playing this is the fact my system is a laptop. I base that assumption off my Fallout 3 not working properly with mobile chipsets, without a hack at least.

Edit: Details I left out. My AV was off the entire time, during installation and updating. My port was forwarded through the router and my firewall which was also disabled. All background programs I could close, were closed. I did disconnect once during updating, reconnected and it seemed to continue running smoothly.

Edited, Sep 22nd 2010 9:51pm by Bipolarbill
#2 Sep 22 2010 at 7:56 PM Rating: Decent
**
696 posts
Confirm that you DO NOT have compatibility mode turned on for another system while it is crashing now? That has caused issues(I think it has a different error but this is my first guess)
#3 Sep 22 2010 at 7:58 PM Rating: Decent
8 posts
No, I originally had compatibility turned off when I first tried it. I turned it on in hopes it would be an easy fix, I turned it off after finding out otherwise.
#4 Sep 22 2010 at 8:10 PM Rating: Decent
**
696 posts
Hmm. Can you get the crash details from event viewer?
#5 Sep 22 2010 at 8:11 PM Rating: Good
**
472 posts
I am guessing that it is a laptop problem. Try using other drivers (outdated) or beta. That really is all I have that I can think of.
#6 Sep 22 2010 at 8:14 PM Rating: Decent
8 posts
This is what I got from event viewer, not sure which part you're looking for:

-General-
Faulting application name: ffxivgame.exe, version: 1.0.0.0, time stamp: 0x4c953104
Faulting module name: msvcrt.dll, version: 7.0.7600.16385, time stamp: 0x4a5bda6f
Exception code: 0xc0000005
Fault offset: 0x00009b60
Faulting process id: 0x8568
Faulting application start time: 0x01cb5ab824b81f74
Faulting application path: C:\Program Files (x86)\SquareEnix\FINAL FANTASY XIV\ffxivgame.exe
Faulting module path: C:\Windows\syswow64\msvcrt.dll
Report Id: 671f0ccf-c6ab-11df-8189-c446194b9199

-EventData-
ffxivgame.exe
1.0.0.0
4c953104
msvcrt.dll
7.0.7600.16385
4a5bda6f
c0000005
00009b60
8568
01cb5ab824b81f74
C:\Program Files (x86)\SquareEnix\FINAL FANTASY XIV\ffxivgame.exe
C:\Windows\syswow64\msvcrt.dll
671f0ccf-c6ab-11df-8189-c446194b9199
#7 Sep 22 2010 at 8:20 PM Rating: Decent
Scholar
*
148 posts
Still sounds like a driver issue.. Possibly have got the latest version but still have bits and pieces of the previous version.. You need to uninstall the video drivers, reboot into safe mode, run driver sweeper, reboot again, then reinstall the drivers, reboot again and you should be good..

Still having problems... It might be your windows install is corrupted..
Run a regular scandisk..
Then do a Start -> Run -> sfc /scannow

#8 Sep 22 2010 at 8:23 PM Rating: Decent
Scholar
*
148 posts
The error that's thrown is an "Access violation error".. Which could just as easily be a trojan or other virus messing with your system dlls as well, but it's more likely a bit of corrupt data in a windows dll that's causing memory pointer to go to a screwy location and throw the access violation.
#9 Sep 22 2010 at 8:24 PM Rating: Decent
**
696 posts
Raspounch wrote:
Quoted TextI @#%^ing found the problem for those of you having the game crashing at startup with the Fault module : msvcrt.dll

It's because of nvidia Optimus, FFXIV just started with the integrated Intel chip which couldn't lead anywhere good. And the supposed automatic switch to the real graphic card didn't occure, so crash.

The workaround I found is to open the nvidia Control Pannel (from a right click on desktop for example)
In 3D Settings -> Adjust image settings -> choose the middle option "Use the advanced 3D image settings"
then in 3D Settings -> Manage 3D settings -> Global Settings tab -> Choose "high-performance NVIDIA proc instead" of "Auto-select" for Preferred graphic processor

Then have another fresh start and cross your fingers, when the Square Enix logo popped up I just couldn't beleive it.

Anyway a massive amount of people are having this problem I don't know if it will solve everyone's but I beleive if your faulting module is msvcrt.dll in Event Viewer and you have nVidia card it must be it.

PS: if you have Optimus Test Tool from nVidia which shows you when your nvidia GPU turns on, you'll see that it just doesnt turn on when ffxiv is starting if you have auto-select enabled, and crashes, after making the update it immediatly turns on and the game runs smoothly


I found this in another post here that has the same file failing as yours. I think that they were also using a 300 series vid card. I'm too lazy to track it down but i know several others in the thread were

Exception code: 0xc0000005 is it trying to access memory that it's not allowed to mess with

Hope this helps some.

Edited, Sep 22nd 2010 10:25pm by zoltanrs
#10 Sep 22 2010 at 8:29 PM Rating: Decent
8 posts
I'll try the steps you mentioned after it gets done... if it gets done updating. Open to other advice as well.

Edit: @Zoltanrs That very well could be the problem. I hope it is at least, that optimus crap has really been a burden more than anything. I do however have the global setting set to use the NVIDIA card rather than the lolIntel chipset. Still, I'll try that and see how that goes.

Edited, Sep 22nd 2010 10:32pm by Bipolarbill
#11 Sep 22 2010 at 8:31 PM Rating: Decent
Scholar
*
148 posts
...Or even more it could be just random memory corruption caused by incorrect voltage or timings on your RAM.. There's a lot of things that can cause memory access violations like that.. The drivers would definitely be the first place I'd be looking myself.. Something is trying to access something that it shouldn't be.. Either because it's corrupted on the disk or after it enters RAM or it's simply referring to something that doesn't exist anymore because your driver installation is screwy or your hard drive filestructure is damaged (corrected with scandisk).
#12 Sep 22 2010 at 8:35 PM Rating: Decent
**
696 posts
Yeah this game has video driver compatibility issues across the board I think. They hit that sweet spot in development right with dx9 to dx 11 moves and with so many variations it amazes me that things are working as well as they are. Sidicus is right tho theres a blue million things that could be wrong. I'm just hunting the obvious and already fixed for someone answers first. Hopefully save some time lol

My gts 250 blew up yesterday and is in RMA ville right now anyways so if I can't play the game I might as well help others try to get things working lol.

Edited, Sep 22nd 2010 10:37pm by zoltanrs
#13 Sep 22 2010 at 8:40 PM Rating: Decent
8 posts
Yeah I can tell lol. I have a good feeling about these suggestions though, but I try not to get my hopes up with anything related to computers. Worst case scenario I could just buy the PS3 version and sell my PC discs with the PS3 code, but obviously I'd rather use my PC to play. :/

Edited, Sep 22nd 2010 10:41pm by Bipolarbill
#14 Sep 22 2010 at 8:59 PM Rating: Good
**
472 posts
#15 Sep 22 2010 at 10:00 PM Rating: Decent
8 posts
I'm going to guess switching to the high performance card worked, in the NVIDIA settings. I re-installed and re-updated, told it specifically to use the NVIDIA card (not indirectly through global application), booted it up and heard the Square-Enix sound effect and my mood changed entirely. :) Thanks for all the help guys, I really do appreciate it. See you in game!
#16 Sep 22 2010 at 10:02 PM Rating: Decent
**
696 posts
Awesome man! Have some fun for me till my card gets fixed lol
#17 Sep 23 2010 at 4:25 PM Rating: Decent
4 posts
I tried playing with the benchmark and the regular client and nothings working for me. I click on the file and it just opens and goes blank then tells me "program has stopped working" like 3 seconds later. My video card is a 1GB ATI Radeon Mobility HD 5730. I just bought my alienware m15x just a month ago. Please help because i dont know what to do to fix this.
#18 Sep 23 2010 at 4:57 PM Rating: Decent
**
696 posts
You need to use the forum search and find one of the many ATI card problems that are posted. They mostly have the same solution.
#19 Sep 23 2010 at 7:12 PM Rating: Decent
4 posts
Do you think you can maybe send me a link to one of the threads? i found some but im not sure which one to do. Im not really good with all this.
#20 Sep 26 2010 at 1:36 PM Rating: Decent
9 posts
The error my friend is getting is this

Faulting application name: ffxivgame.exe, version: 1.0.0.0, time stamp: 0x4c9a72c1
Faulting module name: msvcrt.dll, version: 7.0.7600.16385, time stamp: 0x4a5bda6f
Exception code: 0xc0000005
Fault offset: 0x0000a073
Faulting process id: 0x102c
Faulting application start time: 0x01cb5dae2db4872b
Faulting application path: C:\Program Files (x86)\SquareEnix\FINAL FANTASY XIV\ffxivgame.exe
Faulting module path: C:\windows\syswow64\msvcrt.dll
Report Id: 6c0ef070-c9a1-11df-9897-00266c44841a

She is running on a laptop that can run WoW and Guildwars and several other 3d games why is this one giving her a problem? Attempting to update her drivers didnt work
This forum is read only
This Forum is Read Only!
Recent Visitors: 15 All times are in CST
Anonymous Guests (15)