Forum Settings
       
This Forum is Read Only

How i fixed my DirectX errorFollow

#1 Sep 23 2010 at 8:52 AM Rating: Excellent
7 posts
Well I to like so many others ran into hard times with FFxiv, My problem was everytime i pressed "start game" it would start to load then i would get a directX error popping up , soon after the game would crash.

I tryed everything i mean everyhting, Driver update, Windows update, about 20 different resolutions, and switched from VGA to HDMI. I even tryed to disable the event error 4101, my problem is my video card times out and resets itself error 4101.

after going into the regestry and discovering it doesnt help, I tryed the last thing i could short of reinstalling (witch i did anyways before this dont know why I didnt include it up top and it would be easer to just erase and add it but ill do it the hard way)

My Video card is a Ati Readion 5770

I turned my GPU down to 850 mhz and the memory to 1200 MHZ started the game and it ran perfectly.

So all of you out there with the 5770 or 5 series i would defenetly try to DownClock to 850/1200 it works for me!
#2 Sep 23 2010 at 8:55 AM Rating: Excellent
Anterograde Amnesia
Avatar
*****
12,363 posts
Lord yes, if you are getting game crashes and your graphics card is overclocked, returning it to stock settings should be the [blink]VERY FIRST[/blink] thing you do. Edit to add I guess I assumed the OP's card was overclocked to begin with, if not, that's interesting that downclocking worked. I expect that ATI and nVidia will release new drivers hopefully soon, I know nVidia's 260 beta drivers have support for the XIV benchmark, maybe they will include support for the retail release as well.

The importance of this warranted the blinking tags, yay for admin powers!

Edited, Sep 23rd 2010 10:05am by Wint
____________________________
"Choosy MMO's choose Wint." - Louiscool
The greatest trick the devil ever pulled was to convince the world he didn't exist.
Keyser Soze - Ultros
Guide to Setting Up Mumble on a Raspberry Pi
#3 Sep 23 2010 at 8:59 AM Rating: Decent
18 posts
Sorry, stupid question, but how do you downclock? I'm having the same problem...
#4 Sep 23 2010 at 9:03 AM Rating: Excellent
Anterograde Amnesia
Avatar
*****
12,363 posts
Aueen wrote:
Sorry, stupid question, but how do you downclock? I'm having the same problem...


Have you overclocked your card? If not, you will probably need to download a tool for it, software like EVGA's Precision (if you own an EVGA card). What kind of card do you have?

Edit: Also, if you haven't overclocked, I'm not sure if you will have the same luck, but possibly.

Edited, Sep 23rd 2010 10:04am by Wint
____________________________
"Choosy MMO's choose Wint." - Louiscool
The greatest trick the devil ever pulled was to convince the world he didn't exist.
Keyser Soze - Ultros
Guide to Setting Up Mumble on a Raspberry Pi
#5 Sep 23 2010 at 9:07 AM Rating: Decent
18 posts
I have a mobility Radeon HD 5870
#6 Sep 23 2010 at 9:09 AM Rating: Decent
7 posts
It will not hurt to try and downclock your Ati card like i said it worked for mine, and you have a HD 5 series its the same driver so it could still be related.
you can downclock/upclock ati cards using the catyist control
#7 Sep 23 2010 at 9:16 AM Rating: Excellent
Anterograde Amnesia
Avatar
*****
12,363 posts
gooshpoo wrote:
you can downclock/upclock ati cards using the catyist control


Good to know, thanks! Smiley: thumbsup
____________________________
"Choosy MMO's choose Wint." - Louiscool
The greatest trick the devil ever pulled was to convince the world he didn't exist.
Keyser Soze - Ultros
Guide to Setting Up Mumble on a Raspberry Pi
#8 Sep 23 2010 at 9:18 AM Rating: Decent
18 posts
I can't seem to find where to upclock/downclock the card in my Catalyst Control =/
#9 Sep 23 2010 at 9:24 AM Rating: Decent
7 posts
Its called Ati Overdirve
#10 Sep 23 2010 at 10:42 AM Rating: Decent
18 posts
Hmmm.... Not sure if I can overclock or downclock the laptop ATI cards =/
#11 Sep 24 2010 at 6:09 AM Rating: Good
*
155 posts
Try using a program called MSI afterburner.

It works on non MSI GFX cards as well (not sure about mobility though).
It allows you to adjust fan speeds as well as clock speeds.
____________________________
In this life you are nothing without someone else to think so.

#12 Jan 05 2011 at 8:05 AM Rating: Decent
Scholar
20 posts
I am having the same problem with my Geforce 8800 GT-OC. When it loads it will freeze up or it will go through and crash shortly after. Last time it happend it reset my resolution and put me back to only one display ( I have two) What's messed up is that I can't get my second display back up nor the correct resolution. I am going to try and redownload my drivers and directx again.
____________________________


Necro Warning: This post occurred more than thirty days after the prior, and may be a necropost.
#13 Jan 05 2011 at 9:21 AM Rating: Decent
Scholar
20 posts
Hmmm, I believe FFXIV has killed my graphics card. Windows keeps stopping the card due to hardware problems. I have tried everything from redownloading, reinstalling, and reseating. Oh well... gives me a reason to buy a better card I guess.
____________________________


#14 Jan 05 2011 at 9:26 AM Rating: Good
Scholar
***
1,151 posts
Check and see if the card is overheating while playing the game. If it starts to overheat windows will reset the drive to stop the card which drops you out of FFXIV.
#15 Jan 05 2011 at 12:31 PM Rating: Decent
Scholar
20 posts
The card did seem to overheat a couple times then. The last time I tried to play, it froze on start-up. I got out of FFXIV and my desktop was lined with dots like an old nintendo game crashing. Now windows has stopped my card (says: Windows has stopped this device because it has reported problems. (Code 43) under device manager > card properties) Don't know if there is a way to work around that....


EDIT: the glitchy screen that I mentioned above no longer happends except when I first start my computer and it shows the graphics for my motherboard. After that, in Windows, it is fine but I guess that is due to windows not running that card except as default video.

Edited, Jan 5th 2011 1:38pm by xvvolvenx
____________________________


#16 Jan 05 2011 at 5:39 PM Rating: Decent
Scholar
Avatar
***
1,235 posts
I have a 5770 and have the OC turned on just for fan control, but have never had a Directx error on start up. I'm curious as to what else you have going on rig and OS - wise.

That info would be great if you have the time to post it for troubleshooting potential issues that may pop up in updates for other 5770 users.
____________________________


"Don't take it personally man, white knights would eat a can of **** if the label said SE on it. If anyone dared mention that it was not a good product, they'd just argue if someone can't appreciate the subtle nuances in the ****, they should just go back to eating lolrealfood, cuz the devs prolly know more about canning food than they do."
#17 Jan 05 2011 at 6:41 PM Rating: Decent
Scholar
**
602 posts
I had to do this with my card: MSI Hawk ATI 5770. I believe it is overclocked from the beginning. Basically my problem is that it would crash when messing with Aero, at random would lock up system. Sometimes it would recover with the ATIx.x display driver has crashed, other times I would just hard reset. So I did a lot of research and found MSI Afterburner. Basically loaded the program up, checked it to start on windows startup, set my 2d/3d profiles to the value that I saved in position 1 from hitting Reset on the main window.

You also have to turn on UnofficialOverclocking that is in msiafterburner.cfg in the program files directory, might be named something else. To turn it on, change 0 to 1.

Since then I have had 0 problems with any games. It seems that ATI's firmware for the 2d/3d powersave mode is set a tad too low or something. You could always go the hardcore route and flash your own GPU firmware but I didn't want to mess with it. Pretty sure it's not MSI's fault. All ATI. But problem solved with a little program and research. Better than waiting on a RMA only to get the same error.

Like I said, best permanent fix would be to set the 2d/3d lows in the BIOS firmware. Otherwise use the program and it'll keep the minimum at highest setting. 2d is normally 157/300, video mode is 400/900 and 3d gaming is 900 (875 with afterburner)/1200.

Edited, Jan 5th 2011 7:44pm by Excenmille
This forum is read only
This Forum is Read Only!
Recent Visitors: 18 All times are in CST
Anonymous Guests (18)