Forum Settings
       
This Forum is Read Only

Do I need Windows SP3 to run FFXIV?Follow

#1 Sep 24 2010 at 10:20 AM Rating: Decent
24 posts
About the Windows Service Pack 3... I downloaded one and it completely crashed my computer... Do i really need it? Hmm.. does someone know where i can download a Windows SP3? Or can anyone help me :/
#2 Sep 24 2010 at 10:29 AM Rating: Good
**
516 posts
SP3 is a Service Pack from Microsoft that came out 2 years ago. You can get it direct through Windows Update. I'm assuming you don't update very often so you'll have to do a windows update 4 or 5 times as a lot of the security patches require you to restart after each install.
____________________________
"Plaque is a figment of the liberal media and the dental industry to scare you into buying useless appliances and pastes."
#3 Sep 24 2010 at 12:24 PM Rating: Decent
24 posts
lol noo i dont unfortunately but this was very helpful updating now thank you very much :) i assume this is what i need for FFXIV?
This forum is read only
This Forum is Read Only!
Recent Visitors: 20 All times are in CST
Anonymous Guests (20)