Forum Settings
       
This Forum is Read Only

Gear damage bug?Follow

#1 Oct 10 2010 at 7:27 AM Rating: Decent
7 posts
I have had the gear damage icon appear on my character but all of my gear was fine yesterday when I logged off. I have unequipped all of my gear and I still have the icon. Has anyone else had this issue?
#2 Oct 10 2010 at 7:47 AM Rating: Good
*
239 posts
I heard of a LS mate who had the same issue, he logged in one day and some of his gear was broken. We all joked that we had hacked his account, logged on while he was sleeping, and broke his stuff. but yeah, now your the second person I've heard of saying their gear broke on it's own. Good news: if it shows up while naked, then just the undies are broken and those are cheap to have the NPC fix!
#3 Oct 10 2010 at 8:32 AM Rating: Good
Scholar
***
1,131 posts
Easy enough to check: just go by the local repair NPC and see what they have to say. Since underclothes have so little durability, anything that causes them to wear can wear them out quickly (and you can't take them off unless you've bothered to buy some replacements). Most likely that's what the issue is, and as mentioned it's very cheap to repair those. :)
____________________________
FFXI: Triane [Caitsith], Retired
DRK75, THF75, RDM71

FFXIV: Triane Rhiga [Besaid]
Pugilist, Marauder, Fisher
#4 Oct 10 2010 at 8:41 AM Rating: Good
*
50 posts
Tweezle120 wrote:
I heard of a LS mate who had the same issue, he logged in one day and some of his gear was broken. We all joked that we had hacked his account, logged on while he was sleeping, and broke his stuff. but yeah, now your the second person I've heard of saying their gear broke on it's own. Good news: if it shows up while naked, then just the undies are broken and those are cheap to have the NPC fix!


Either that or you'll need a viagara prescription..
____________________________

[ffxivsig]1793959[/ffxivsig]
#5 Oct 10 2010 at 8:45 AM Rating: Good
***
2,815 posts
I also had some gear damage bugs.
I had JUST come from the repair NPC, i had repaired everything, had no damage icon of any kind.
My LS were on the way to party, we met at the camp, start walking together... Then i notice the red gear Icon.... WTF? I knew for SURE that just minutes before, i had no damage icon. How can it possibly go straight to red on anything now? Especially since it's been 10 minutes since repair and all i've done is stand and walk a little.

I un/re-equipped a random piece of gear to force it to refresh... It turned yellow...

I gave up. It's bugged.

Edited, Oct 10th 2010 11:33am by RattyBatty
____________________________
Minecraft : My anti-MMO
Terraria : My anti-Minecraft
#6 Oct 10 2010 at 8:54 AM Rating: Decent
Avatar
***
3,005 posts
maseiko wrote:
I have had the gear damage icon appear on my character but all of my gear was fine yesterday when I logged off. I have unequipped all of my gear and I still have the icon. Has anyone else had this issue?


You can't have unequipped all your gear because you must still have a main weapon/tool, undershirt, and underpants. If you've checked all those and they're all over 50%, call a GM.
____________________________
Chris Mattern
#7 Oct 10 2010 at 9:16 AM Rating: Good
Scholar
**
250 posts
What about your accessories like rings and earrings?
____________________________
FFXIV
Name : Kronon Reinhart
Server : Gysahl
Jobs : R24 Fisher, R23 Culinarian, R15 Gladiator

FFXI (retired)
Name : Kronon
Server : Lakshmi
Jobs : 75Drk 60Blm, 37 War/Thf/Nin/Sam
#8 Oct 10 2010 at 12:22 PM Rating: Good
*
112 posts
Yup, I had that happen too. I was doing my leves out at Uld's lvl 10 camp, and when finished, I had no damage icon. Walked back to Uldah, no damage icon. Sometime while wandering in Uldah, checking out bazaars, my dagger got damaged and showed the icon.

O.o
____________________________
You know you've been playing too many MMOs when:

You pass a cop and wonder if it 'Agroed' you.
Another car passes you, you attempt to /follow it.
You use your "push to talk" key while talking on the phone.
Text-based games You put a /s before every message you type in an IM (or equivalent / command)
(I have done all)
#9 Oct 11 2010 at 10:25 PM Rating: Default
7 posts
OMG I have contacted SE through the support site and through GM. I'm standing in the same spot in Limsa for 2 days wearing nothing but my underwear and my bow. SE support staff is just about as poor as Dell. They really don't care whether they are helpful or not. If someone has had the problem fixed before please tell me what you did.
#10 Oct 12 2010 at 1:25 AM Rating: Decent
I started getting that today. All of my gear was well over 50% except my sewing needle (of all things). When I repaired that, the red icon remained. It has remained through diligent double-checking of durability and several gear swaps. All of my underwear is just fine.

The thing is, it's really not worth getting worked up over. It's just an icon on your screen. It doesn't affect you at all. If you're so irritated by a simple icon on your screen that you feel compelled to hassle SE's support staff about it, maybe you need a break. They can't do **** for you when it's a bug like that. The best they can do is catalog it and pass it along for SE to make sure they know about it and aim for a fix in the near future. Until then, best bet is to just learn to live with it. It's not the end of the world. You aren't penalized simply for having the icon present. You're penalized on individual gear pieces that reach a certain threshold. If they're not below that threshold, there's no penalty regardless of what the icon would have you believe.
#11 Oct 12 2010 at 1:38 AM Rating: Good
***
2,815 posts
Quote:
The thing is, it's really not worth getting worked up over. It's just an icon on your screen. It doesn't affect you at all.

The annoying part is that it hides your true gear damage. So something might well become red for real, and you'll likely not know.

It's like if the gas meter was always on empty in your car. You might be actually out of gas someday and have no idea til it breaks down.
____________________________
Minecraft : My anti-MMO
Terraria : My anti-Minecraft
#12 Oct 12 2010 at 1:49 AM Rating: Good
RattyBatty wrote:
Quote:
The thing is, it's really not worth getting worked up over. It's just an icon on your screen. It doesn't affect you at all.

The annoying part is that it hides your true gear damage. So something might well become red for real, and you'll likely not know.

It's like if the gas meter was always on empty in your car. You might be actually out of gas someday and have no idea til it breaks down.


Okay. I guess. I just can't see it as ever being anywhere near so significant that I'd not only try and get ahold of SE support to fix it but take it a step further and get all butthurt when they can't. It's an irritant. Nothing more. It's a post-release bug that will be worked out in time.
#13 Oct 12 2010 at 2:18 AM Rating: Decent
Scholar
16 posts
I knew in the beta that even ur underwear can take damage but havnt seen if still can
#14 Oct 12 2010 at 4:29 AM Rating: Excellent
***
1,146 posts
I didn't have any problems with gear damage so far. If it showed something is broken there really was something that needed repairs.

However. I had another interesting thing happen to me a few times now.
When I switched to a DoH and had gear damage (yellow), suddely after one or two synths the gear damage was gone...I do swap some gear when changing classes but I didn't see anything damaged enough for the gear damage effect.

There really seems to be something fishy about the durability system sometimes.

But you should check your rings, chokers, earrings and underwear. Most of the time one of these is making trouble.
____________________________
[ffxivsig]298447[/ffxivsig]
Final Fantasy XI
Server: Quetzalcoatl
Name: Kyana (retired)
Jobs: THF75 PLD70 BST70

#15 Oct 12 2010 at 8:05 AM Rating: Decent
**
548 posts
Quote:
What about your accessories like rings and earrings?


Kronon wins this thread. Nothing is glitched, you are actually wearing heavily damaged ring(s) and/or accessories.

When you go to the repair NPC and click "repair all", rings and accessories apparently don't count as "all". To check gear durability, the easiest way I found is to look at the gear in the inventory tab, NOT under the gear and attributes tab. (Why would you ever check gear durability under the gear tab, that doesn't make any sense...)

If you scroll through your inventory to your currently equipped items, you'll see a number in the lower left corner that will be displayed as #####/#####. This is the durability of that item. Check the durability of your rings / accessories.

I haven't really looked into what processes or mats are required to repair jewelry, but at lowbie levels, I'd just as soon buy new ones before I waste my time figuring out how to repair. It's probably cheaper too.

____________________________
MUTED
#16 Oct 12 2010 at 8:35 AM Rating: Good
*
73 posts
A few folks mentioned this allready, but check your accessories. The NPC does not repair Accesories.
This includes rings, chokers, bracelets. Additionally he will not repair all gear to 100%.

Once you leave the newbie stuff it's 75% or so. I had him refuse to repair a pair of boots over 60%, but I haven't figured out why. It's possible that repairing it will still bering it to bellow the damaged threshold.

Additionally, repair all equipped gear does not include the main/offhand when i use the repair NPC. The Main hand Off hand are listed individually on the same menu.

Edited, Oct 12th 2010 10:36am by Vladislaus
#17 Oct 12 2010 at 9:31 AM Rating: Decent
DonFlamenco wrote:
Quote:
What about your accessories like rings and earrings?


Kronon wins this thread. Nothing is glitched, you are actually wearing heavily damaged ring(s) and/or accessories.


That's not necessarily true. I don't have any accessories. At all. Not one. Haven't worn any since CE launch, and I'm still stuck with a red icon even though all of my gear is perfectly fine.
#18 Oct 15 2010 at 4:54 PM Rating: Decent
3 posts
Had same problem. Causing a few tiny points of equipment damage by crafting something was enough to make it update and for the icon to go away for me.
#19 Oct 15 2010 at 6:12 PM Rating: Decent
Scholar
***
1,098 posts
My gear constantly takes damage from Macro switching between jobs even when I'm standing still i thought this put in the game to stop you from switching jobs to often. I was going to make a thread asking should i remove all my gear with macro first then put another gear set on to stop this.
____________________________




[ffxivsig]459049[/ffxivsig]
#20 Oct 15 2010 at 6:36 PM Rating: Default
**
441 posts
i had nothing wrong with my gear, until i step out of the city all of a sudden my gear broke o.O' seriously freak me out i ran back in and had npc fix my gear all was good walk back out the city the icon appeared again wtf is going on.
____________________________
[ffxivsig]734467[/ffxivsig]
http://sigs.enjin.com/sig-ffxiv/28008_783e991ed00530dc.png
#21 Oct 15 2010 at 6:37 PM Rating: Good
Scholar
**
339 posts
This brings up the question?

What is the point of undergarments?

We can only equip one type (that I know of) so its not if we can upgrade them. And they offer little support.

Yet we still have them damaged and have to reair them. Why? It seems to be just a time waste.
#22 Oct 15 2010 at 6:38 PM Rating: Decent
Scholar
***
2,742 posts
Maybe once we hit level 30 we can go dungeon hunting for RSE >.>b
____________________________
FFXIV: Karamethien Seraphus (Blog)

FFXI: Karamethien
Still a Seraph Samurai Wanna Be
Fishing AF - Complete, SAM AF - Complete, RNG Af - Complete, RDM AF - 1/6
#23 Oct 15 2010 at 6:47 PM Rating: Good
***
2,815 posts
Quote:
Kronon wins this thread. Nothing is glitched, you are actually wearing heavily damaged ring(s) and/or accessories.


As i said in my account of the bug, my accessories were fine. And i went from no damage icon, to red damage icon just from walking for 5 minutes. There are several things wrong with that :

1- Just had my stuff repaired
2- Went straight to red icon, bypassing yellow
3- Wasn't even doing anything damaging.
4- Nothing is damaged below 50%

So yeah, there is some sort of bug that does happen.
____________________________
Minecraft : My anti-MMO
Terraria : My anti-Minecraft
#24 Oct 15 2010 at 7:53 PM Rating: Default
*
69 posts
Video or it didnt happend.

But for real, this would help to prove your case.
#25 Oct 15 2010 at 8:03 PM Rating: Good
Ya, same thing happened to me today, I logged off, no damage. Logged in, and my Bow was damaged. Quick fix since I have my carpentry up, but still very odd since I hadn't used it all day.
____________________________

#26 Oct 15 2010 at 8:08 PM Rating: Default
*
69 posts
You may have nailed it bang on, maybe the damage isnt up to date. A delay comes to mind, when you log out and back in, it updates the damage that was previously calculated or something?

So like I use my dagger for 4 hrs, worth lets day 50,000 dmg. However, my dagger was already at 17000/99000
I didnt use any durability during that time, i go repair my dagger, I log out. The server says hey wait a minute, this dagger has 50,000 un allocated dmg points so im going to apply them now since I check the rules and theres durability available.

Yeah?
This forum is read only
This Forum is Read Only!
Recent Visitors: 26 All times are in CST
Anonymous Guests (26)