Forum Settings
       
This Forum is Read Only

Exaltation not working - THM 10Follow

#1 Oct 10 2010 at 6:42 PM Rating: Decent
18 posts
Im a THM rank 10. Had Exaltation for a while, but it never worked. It's in my main combat bar. Active or Passive Mode...nothing.


Am I doing something wrong?
#2 Oct 10 2010 at 6:44 PM Rating: Decent
**
317 posts
Check this out

http://ffxiv.zam.com/en/ability.html?ffxivability=28484

Starter Quests or something
____________________________
Caaaaaaaaaaaaaaarl

Carl - "Shhhh, do you hear that? That is the sound of forgiveness."
"That is the sound of people drowning Carl."
Carl - "That is what forgiveness sounds like, screaming and then silence."
#3 Oct 10 2010 at 7:05 PM Rating: Decent
18 posts
I have the ability...it just wont activate. It's in my main action bar.
#4 Oct 10 2010 at 7:12 PM Rating: Good
**
317 posts
Strange, are you the right class? Oh make sure you have enough action points, that was causing me problems, also you might have to have a certain weapon .
____________________________
Caaaaaaaaaaaaaaarl

Carl - "Shhhh, do you hear that? That is the sound of forgiveness."
"That is the sound of people drowning Carl."
Carl - "That is what forgiveness sounds like, screaming and then silence."
#5 Oct 10 2010 at 7:24 PM Rating: Decent
Scholar
**
706 posts
ktwice wrote:
I have the ability...it just wont activate. It's in my main action bar.


It can only be used on THM, and there's a 10 Min CD on it from when you set it.

Outside of that, I can't see any reason why you can't use it, so best to try a Log Out and if that still doesn't work, try getting in touch with a GM
____________________________
Server = Remora - Rank 10 Windurstian

Menchi
Tarutaru
75 BLM (Main)
37 WHM
37 RDM
25 SMN (Future Main ^^)
ZM Complete - CoP Complete - Windurst - Complete
LS - Dragonflies
#6 Oct 10 2010 at 7:27 PM Rating: Decent
If you try using it when you don't have a full stamina bar, it will wait until your stamina bar recharges before it will activate. It requires all of your stamina to use.
#7 Oct 10 2010 at 10:53 PM Rating: Decent
24 posts
Make sure it's set to main hand, and see it using the action points when equiped.

Edited, Oct 11th 2010 12:53am by bigalohelper

Edited, Oct 11th 2010 12:54am by bigalohelper
#8 Oct 12 2010 at 9:05 AM Rating: Decent
18 posts
Thank you for the responses, everyone.

Not sure if I had full stamina when i tried to use it. I may not have it in my main hand either. I will give those a try when i get home this eve.

Thanks again!
#9 Oct 12 2010 at 9:37 AM Rating: Decent
Scholar
***
1,151 posts
IF the above doesn't fix then remove it from your action bar and readd it to the bar.
This forum is read only
This Forum is Read Only!
Recent Visitors: 22 All times are in CST
Anonymous Guests (22)