Forum Settings
       
This Forum is Read Only

The PC and Settings Optimization ThreadFollow

#1 Oct 12 2010 at 9:31 AM Rating: Decent
Scholar
30 posts
If we already have something that specifically covers this I apologize, but I think we need to get together and see what solutions there are for those with moderate systems but poor performance. What I'm playing with:

i7-870 @ 3.7ghz
4GB DDR3 2ghz
BFG GTX285OC 1GB card @ 775mhz
3x Seagate 500gb hard drives in RAID0
Killer Gaming NIC
win7 x64
1280x720 screen resolution

nVidia Control Panel set to performance, force vsync, triple buffering, no AA or AF.

Game Config Settings:
Full Screen
1280x720
Resolution: Standard
Textures: Standard
Texture filtering: Low
all check boxes disabled except for Hardware mouse
Shadows: Low

Ingame Settings:
Everything is on except for extended draw

Extended Drawing enabled: 18-25fps in camps and cities, 40+ in low population.
Extended Drawing disabled: 30-40fps in camps and cities, frames will cap at 60 in low population.

As you can see, turning off Extended Drawing was huge for me. I started off by disabling everything in the ingame config and one by one re-enabling them. Physics, Shadows, etc. all incurred a 1-2fps hit to my system but extended draw was what really brought it to it's knees. ALL load times are also much better now, including teleporting. I may tinker with settings like shadows or occlusion now to see if I can get a little better eye candy but i'm fine with the way it's performing as is.

EDIT: disabling Extended Draw removed some renderings from the distance, such as trees that were on far-off mountains and such. I can handle that, seems like a good tradeoff for better performance.

I have a far weaker system that I might tinker with tonite, if I have any significant results I will post them up.



Edited, Oct 12th 2010 11:33am by ogboot

Edited, Oct 12th 2010 11:34am by ogboot
#2 Oct 12 2010 at 9:57 AM Rating: Default
1 post
WOW... did you even update your gpu driver??

i am playing this game with only
Q9550 @ 2.8 ghz stock.

6 Gb ram at 800 mhz

and
480 gtx stock .


i am playing it at 1920 x 1200, everything max besides the occlusion thing.


and i am getting great fps beside from town.
#3 Oct 12 2010 at 10:04 AM Rating: Decent
Scholar
30 posts
Yes the system is completely up to date, it's the 2 series card holding me back. Your 4 series is much more apt to handle the game. Have you actually checked your framerate? I can crank it up and the game will play "fine" but it's only running at about 18fps.
#4 Oct 12 2010 at 10:06 AM Rating: Decent
**
415 posts
wc326 wrote:
WOW... did you even update your gpu driver??

i am playing this game with only
Q9550 @ 2.8 ghz stock.

6 Gb ram at 800 mhz

and
480 gtx stock .


i am playing it at 1920 x 1200, everything max besides the occlusion thing.


and i am getting great fps beside from town.

Compare your graphics card to his. It's really no comparison.

@OP, you should be able to run with Textures and Texture Filtering on High, with Shadows turned off, and up to 1680x1050 resolution if your monitor supports it. My 8800GT ran the game fine at 1680x1050 resolution with everything on High before I upgraded to a GTX 480.

You will lag in crowded areas, regardless.
#5 Oct 12 2010 at 10:08 AM Rating: Decent
Scholar
30 posts
Thanks, Souma. I'm going to start increasing the settings now that I found what really cripples my system (Extended Drawing).
#6 Oct 12 2010 at 11:19 AM Rating: Good
**
472 posts
#7 Oct 12 2010 at 11:31 AM Rating: Good
Scholar
30 posts
Thanks Parsalyn, I had looked a bit but the thread must have been buried.
This forum is read only
This Forum is Read Only!
Recent Visitors: 21 All times are in CST
Anonymous Guests (21)