Forum Settings
       
This Forum is Read Only

Nvidia 260.89 WHQL Follow

#1 Oct 20 2010 at 11:59 AM Rating: Good
Scholar
Avatar
*
86 posts
Quote:
•Improves compatibility for older PC games (DirectX 7 to DirectX 9) running on Windows 7


Yeah FFXIV aint an old game but still a directx 9 game and those drivers improve DX9 on windows 7 great news for me

Download
http://www.nvidia.com/Download/index.aspx?lang=en-us
#2 Oct 20 2010 at 12:08 PM Rating: Decent
***
3,825 posts
They should still have the SLI fix in them for XIV, I haven't confirmed yet though. However both Beta drivers did.
____________________________
FFXI:Sylph - Perrin 75 Hume THF; Retired (At least from my use any way)
EVE Online:ScraperX; Retired
WAR:IronClaw- Peryn SW;SkullThrone- Grymloc BO; Retired


#3 Oct 20 2010 at 12:12 PM Rating: Default
Scholar
Avatar
*
86 posts
guess they want to do some more tweak on Sli before "whqling" it.
#4 Oct 20 2010 at 12:17 PM Rating: Default
Sage
**
447 posts
the release notes say SLI support for DirectX9. score
____________________________
Djigga, please. Highland Hyurs can't jump.

#5 Oct 20 2010 at 12:30 PM Rating: Decent
***
3,825 posts
I'm downloading right now, I just did a few minutes of FPS recording with the newest Beta drivers. I'll post up in another few minutes to show how the WHQL compares in the same area doing the same things.
____________________________
FFXI:Sylph - Perrin 75 Hume THF; Retired (At least from my use any way)
EVE Online:ScraperX; Retired
WAR:IronClaw- Peryn SW;SkullThrone- Grymloc BO; Retired


#6 Oct 20 2010 at 12:41 PM Rating: Decent
Scholar
***
2,742 posts
Upgraded yesterday (did clean install) but it froze on installing 3D vision drivers.

I ended up having to manually install the 3D Vision drivers seperately.

I uninstalled beta driver before this.

So if you encounter the same issue, just log off (to exit the installer, I didn't want to force close with task manager). and install the 3D vision driver manually.

Despite this hickup the drivers seems to work fine. Getting odd artifact in New Vegas (the dust storms at the beginning shows as white squares for a split second) but not sure if that is drivers or bad programming in Fallout.

For all of FFXIV's launch bugs, New Vegas' is worse >.< They screwed up the save system. You have to make a new save each time. Lost 8 hours of play because of it (some online have lost 20 hours worth)
____________________________
FFXIV: Karamethien Seraphus (Blog)

FFXI: Karamethien
Still a Seraph Samurai Wanna Be
Fishing AF - Complete, SAM AF - Complete, RNG Af - Complete, RDM AF - 1/6
#7 Oct 20 2010 at 12:49 PM Rating: Decent
***
3,825 posts
Ok so I only tested in town as I was getting 60fps outside of town most of the time. With everything maxed and at 1900x1200 I got a 6 FPS boost with these drivers. I'm running 2x gtx 470's on an EVGA MoBo, if it even matters.

However at my normal settings in windowed mode, I really didn't notice much visual improvement.

Either way, as far as XIV is concerned I don't have any graphical issues and this WHQL has the SLI fix already implimented (as did the last 2 Beta drivers like I mentioned previously).

Bottom line, from my short testing... there's no reason for Nvidia owners not to upgrade to this driver as far as XIV is concerned.
____________________________
FFXI:Sylph - Perrin 75 Hume THF; Retired (At least from my use any way)
EVE Online:ScraperX; Retired
WAR:IronClaw- Peryn SW;SkullThrone- Grymloc BO; Retired


This forum is read only
This Forum is Read Only!
Recent Visitors: 18 All times are in CST
Anonymous Guests (18)