Forum Settings
       
This Forum is Read Only

UI responsiveness?Follow

#1 Nov 21 2010 at 9:03 PM Rating: Decent
Scholar
*
107 posts
Hey guys, I purchased the CE a while back but havent played since the second week. I expect great tihngs from this game in time and definately plan on returning.

I've looked through the update notes but cant seem to find any info as to wether or not the UI lag is being taken care of, or if it has already.

I've seen some posts about how the game handles porcessing server side (not sure on what this really means) so I'm not sure if its the game itself or my rig...

I just remember how painful navigating through the menus was.

Does anyone happen to know if they plan on speeding things up, and making it more responsive?

Thanks
____________________________
FFXI: Xayne 68/34 Mithran PLD - Retired
WoW: Xain 60 Troll Priest
WoW: Site 59 Orc Hunter
WoW: Umon 43 Human Priest - Retired
Currently: Back to FFXI from a year break - never thought it would happen
#2 Nov 21 2010 at 9:04 PM Rating: Decent
*****
11,576 posts
Yes, they do plan on speeding it up.
#3 Nov 21 2010 at 9:14 PM Rating: Good
Guru
**
691 posts
The upcoming updates, on November 25 and sometime early December will include several improvements to response time across the board.
#4 Nov 21 2010 at 9:31 PM Rating: Good
**
398 posts
They plan on speeding it up, as seen in the above posts, but it's not AS bad as before. It is still there, and you can definitely notice it, but it's not as bad as during beta.

Probably because of the decreased population.


But sometimes it's your own CPU's fault. I find that when getting guildleves normally, I don't have any lag (Most of my UI lag comes from opening/managing inventory). When I'm running X Y and Z programs on my computer while running through guildleve menus, it takes a few seconds to load.
This forum is read only
This Forum is Read Only!
Recent Visitors: 24 All times are in CST
Anonymous Guests (24)