Forum Settings
This Forum is Read Only

Golden Sacrifices Bugg ? Need help Asap!Follow

#1 Nov 27 2010 at 5:56 AM Rating: Decent
4 posts
Dont know if this is a bugg or what, but i just wonder if some1 else have encountered this same problem.

When i did this quest and came to this part:

"Speaking to Niellefresne at Warburton's funeral gained you nothing but his typical curtness. Seek out and speak to Mumuepo of the thaumaturges to see if he might have any further information"

I went out of the building cuz i didnt read my jourlan and thought maby mumuepo was outside.
As i exited the building i notice that i could see players again and that i've gotten a msg in my chat box (leaving instance).
when i THEN started to read my journal, i noticed that i needed to speak with mumuepo...and that he apperently was inside the "instance".. so what now?
Is this a bugg?, in that case is there any way to speak with him or get back into the "instance" ?

apriciate all help :)
#2 Nov 27 2010 at 6:04 AM Rating: Decent
1,449 posts
I assume you've tried going back into the thaumarturge's Guild and nothing happened so the only thing I remember is there there a cut scene that only activates when you try and leave that area going north.


#3 Nov 27 2010 at 6:56 AM Rating: Decent
4 posts
Yeah, tried to go back but still nothing happend, in my journal it stands that i need to see mumuepo, but i cant see him anywhere even if i go to the possision on the map.
any idea what i can do ?
This forum is read only
This Forum is Read Only!
Recent Visitors: 23 All times are in CDT
Anonymous Guests (23)