Forum Settings
This Forum is Read Only

FFXIV Boot Crash (ffxivboot.exe) + Solution :) Follow

#1 Dec 23 2010 at 4:12 AM Rating: Good
33 posts
Hello everyone!

So I was able to rebuild myself a spiffy computer recently and ran into a major XIV breaking hurdle tonight upon a reinstall. My old Dell XPS 410 system ran Windows 7 64-bit just fine and the XIV boot installer / game have given me no problems at all to be honest - loving the game. Had an Nvidia 9800GTX+ in there with I believe at the time, Nvidia 263.06 or so drivers... I forget.

The problem is now that I rebuilt a Xeon system with an SR-2 board and ran into a nasty boot patcher bug I thought I could post about in case anyone has the same issue. Basically, I did a fresh install of XIV on my new system, and loaded the patcher. Patcher was red, thus indicating an upgrade of the FFXIBoot.exe to update that and the game files. The original (I think) ~7-8-10 bootloader was fine. As soon as that process finished to the current bootloader of ~9-15-10, it would *immediately* go gray and give me a "Windows has encountered an unexpected error and is forced to close." dialog. Event viewer gave me a 0xC0...05 error so I ran a RAM test and memory is indeed stable (as it should be).

Now here's where the headache came in. Tried that sound trick to lower my sound frequency from 48Khz to 44.1Khz for some patch issues I read about. No luck. Ran a virus scan, nothing. Ran a registry cleaner (RegAce), cleaned some junk but no luck. Uninstalled and reinstalled completely... no luck! Reverted my current GTX 580 263.99 driver to 262.99 thinking it might be too new of a driver for the game... no luck! Tried right clicking and forcing "Run as Administrator" - again, nothing. Made sure anti-virus and firewall were temporarily off or disabled and the exe was allowed through. Didn't matter what combo of settings, or what was off or on, again no dice.

Was really starting to panic and wonder about torrenting some boot files but I had one more thought to isolate the boot process. Luckily, I'm not sitting here on a call to SE tomorrow as I did find a good solution after a bit.

1. Install XIV as normal (outside of Program Files (x86) is fine). For me for example, it's C:\Final Fantasy XIV

2. Make a temp folder for the boot data (mine was C:\XIV Boot Temp). Go into Install Directory > Square Enix > Final Fantasy XIV then you'll see five files. Boot.ver, the FFXIV.exe, FFXIVConfig, FFXIV Updater, and Game.ver. Go ahead and configure your game first as you would.

3. Copy Boot.ver, Game.ver, and FFXIVboot.exe alone into the main directory of your XIV Boot Temp folder (to revert to as it's needed)!

4. Update the game through the SE patcher like normal. Once the red dialog box finishes, it will have updated the boot version from about a date of ~7-8-10 to 9-15-10. Launch it again and if Windows wants to instantly crash it, don't worry.

5. Copy the current Boot.ver and Game.ver files to a sub-folder of your XIV Boot Temp folder (mine is xivbootver2_7-8-10-to-9-15-10).

6. Important!! Go and *overwrite* the patched FFXIVBoot.exe with the original one that successfully launched the patcher in the first place (the default one with the game disc). There should be about a 1MB discrepency in the file size (old is ~11MB, new is ~12MB). Just copy/paste the XIV Boot Temp's FFXIBoot.exe file and overwite the one in the Square Enix folder, thus forcing the patcher to use the old bootloader.

7. Re-launch the patcher again. Sure enough in my case, no crash. The data file date was incremented from 9-15 to 9-18-10 (the first super big patch), then halfway through, changed to ~11-21-10, then ~12-15-10, then ~12-20-10 or whatever the last file it needs is. Don't know about you but I had anywhere from 30-40 local connections in the southeast Michigan area giving me an average of 800KB/sec to at times, 1.25MB/sec so the whole patch took maybe 25 minutes tops.

8. Copy updated boot.ver / game.ver into sub directory of XIV Boot Temp folder (updated record for me is xivbootver3_9-18-10-to-12-20-10).

9. Let the big patch install and then run your game just fine. All my settings were intact, though I have to simply readjust the widgets and UI and rewrite my macros. Woo I can play again :)

Enjoy. I hope this helps someone in the event they have the same issue I did.

Edited, Dec 23rd 2010 5:14am by Reallink
#2sabbas, Posted: Jul 04 2011 at 3:50 PM, Rating: Sub-Default, (Expand Post) hey i think i'm having this problem, i'm not that computer swavy, you got an email account that i can hit you up on?
This forum is read only
This Forum is Read Only!
Recent Visitors: 13 All times are in CDT
Anonymous Guests (13)