Forum Settings
This Forum is Read Only

Direct X error?Follow

#1 Dec 30 2010 at 5:31 PM Rating: Good
10 posts
i got a new computer a couple of days ago to be able to play high quality games, FFXIV being the main one... now, i keep getting a problem saying "Device not found" and says to restart FFXIV... so i do and then a while later it happens again.
i know you've had this kind of topic posted a million times, so sorry, just that i've tried alot of the things and i really dont know what to do anymore.

this is the computer i have:
as far as i know, that should be fine to run this game, but alas, it keeps freaking out and closing it.

i've installed DirectX 9c so it cant be that
i've updated my NVidia drivers, so it cant be that
i've lowered the graphics down, so it isnt that
i've switched from full screen to windowed so it isnt that either...

what the **** is going on? D:
i really hope someone can help me here...
it's just about playable, but it's obviously a pain in the **** when it closes just in the middle of a levequest and makes you fail it (has happened twice now)

thanks guys ^^;;
#2 Dec 30 2010 at 5:33 PM Rating: Good
28 posts
i get this error when i try to window out of full screen mode or do a few othe rthings when trying to look at other windows with ffxiv up. i think its meant to avoid people using 3rd party stuff while ffxiv is open. do you have any other programs running in the background?

Edited, Dec 30th 2010 6:35pm by Frito3434
#3 Dec 30 2010 at 5:36 PM Rating: Decent
10 posts
absolutely nothing running in the background really, or well, other than MotionInJoy so i can use my PS3 controller anyways.
#4 Dec 30 2010 at 5:39 PM Rating: Good
28 posts
hmm.. i dont know then thats about as far as my pc knowledge goes lol. only thing i can think of is something triggering your pc trying to open a program or something if that even make sense.
#5 Dec 30 2010 at 5:41 PM Rating: Decent
10 posts
mmm, i'm not really sure, i dont think there's anything that should be opening randomly since it's brand new and i havent really installed a great deal of stuff x_O;
tried removing McAffee from my computer (since it's lame anyways)... so maybe that'll help? couldnt close that before so figured it may as well delete it. could it have been that d'you think?
#6 Dec 30 2010 at 5:47 PM Rating: Decent
28 posts
i really dont know to be honest try opening task manager and see if anything is runnning that you cant see.

Edited, Dec 30th 2010 6:48pm by Frito3434
#7 Dec 30 2010 at 6:02 PM Rating: Decent
10 posts
okay so... the removing McAffee did nothing.
i tried playing again and now i get a new message, hurray!
googled, found nothing with any kind of solution... can anyone here help me? D:

"nvidia kernel mode driver stopped working and has successfully recovered"

why computer? why do you do this to me? ;o;
#8 Dec 30 2010 at 6:04 PM Rating: Decent
28 posts
sorry to hear that buty that is way over my head when it comes to pc's but i wish you the best of luck, maybe try in the computer buiilding thread at the top a lot of knowledgable peopel in there.
#9 Dec 30 2010 at 6:19 PM Rating: Decent
10 posts
-sigh- thanks anyways.
i'll figure it out somehow... just really winding me up now. i've tried every suggestion i possibly can find but it isnt working... the only thing i've found that i havent tried is changing my graphics card, but that's far too expensive for my budget :(
#10 Dec 30 2010 at 6:21 PM Rating: Excellent

I get this error whenever my screensaver pops up due to me forgetting to disable it. Is your screensaver turned on perhaps?
#11 Dec 30 2010 at 6:45 PM Rating: Good
35 posts
Hello. The error is caused by a Windows 7 malfunction relating to Nvidia. I would uninstall the driver YOU CURRENTLY HAVE then find and install a Vista 64-bit version of the same thing in compatibility mode. If that fails then maybe try using another OS somehow? XP works great for FFXIV. Although I would try to make Windows 7 work first.

#12 Dec 31 2010 at 1:03 AM Rating: Decent
10 posts
it always happens while i'm in the middle of doing something so i cant imagine it'd be my screensaver. plus it happens at completely random times, sometimes it takes 1O minutes and other times it wont happen for 2 hours :\

i go and do that now, hopefully it'll work ^^
#13 Dec 31 2010 at 2:04 AM Rating: Decent
10 posts
unfortunately didnt work either...

-sigh- would a new, different NVIDIA graphics card help? :\
or even ATI? since i've read now that the 5000 series seems to be better than NVIDIA for FFXIV..

Edited, Dec 31st 2010 3:24am by SnowflakeKisses
#14 Dec 31 2010 at 8:02 AM Rating: Decent
32 posts
There was one evening where I had a similar problem to the OP. What was preventing Direct X from working properly for me was that Java was trying to update.

#15 Dec 31 2010 at 12:13 PM Rating: Decent
10 posts
iunno, it's been happening to me from the day i started playing.
it happens about every 5-10 minutes in the city and every couple of hours outside the city, plus it ALWAYS closes when i come from outside Gridania and go in, every single time without fail.

i'm looking at if i can take my computer back or exchange it for another somehow... maybe i should switch to ATI since they dont seem to have as many problems with it from what i've heard
#16 Dec 31 2010 at 12:18 PM Rating: Good
35 posts
I'm sorry that it did not work. However, I still suspect that either the Nvidia kernel or Windows 7 are failing. The best way is to get as far as possible from the problems, I guess by trying out an ATI graphic card. Be careful so can refund if it fails too.

#17 Dec 31 2010 at 12:23 PM Rating: Decent
10 posts
yeah, it mentions something about the kernel thing... but i cant for the life of me find a solution

i've checked and i should be able to get a refund for this computer and i'll go to a different place who know more what they're talking about so they can hopefully help me figure out what the best option is for me and i'll go from there.

have there been problems with the GeForce 460 that FFXIV recommends, does anyone know? because my boyfriend is planning on getting a computer with that graphics card soon and because of my problems with Nvidia and Windows 7 he's now worried that the same things are going to happen to him.
#18 Dec 31 2010 at 12:38 PM Rating: Good
35 posts
People have had the same problems with 460, but it is driver related. Can you list the graphic options in your FFXIV config(or screenshot)?

#19 Jan 01 2011 at 9:38 AM Rating: Decent
10 posts
eh, i've already taken the computer back.

both me and my boyfriend are going to get computers with ATI graphics cards instead of Nvidia and hopefully should have them by the end of the week. researched and there's very few people who have problems with ATI and FFXIV 'cept the odd easily fixable problem here and there. so fingers crossed, we'll be back to playing at the end of the week.

thanks to everyone for trying to help :)
This forum is read only
This Forum is Read Only!
Recent Visitors: 17 All times are in CDT
Anonymous Guests (17)