Forum Settings
       
This Forum is Read Only

Nvidia Beta Drivers 267.24 (267.26 for GTX 560ti)Follow

#1 Mar 01 2011 at 7:43 PM Rating: Good
Scholar
*
77 posts
New beta drivers are up. Nothing in the notes concerning FFXIV.

From Nvidia:

This is a beta driver release from the Release 265 family of drivers (versions 265.xx to 269.xx). You can read more about this family of drivers on GeForce.com.

This driver package supports GeForce 6, 7, 8, 9, 100, 200, 300, 400, and 500-series desktop GPUs as well as ION desktop GPUs.

New in Release 267.24 (267.26 for GTX 560ti)

•Adds 3D Vision support for Bulletstorm.
•Adds SLI support for Homefront.
•Improves compatibility with Dragon Age II.
•Fixes an issue where the NVIDIA control panel may not be accessible via the Windows desktop.
Other

•Installs HD Audio driver version 1.1.13.1
•Installs PhysX System Software to version 9.10.0514
•Users without US English operating systems can select their language and download the International driver here.
____________________________
FFXIV Sterling Cooper - Besaid

FFXI Cheebone - Unicorn
#2 Mar 02 2011 at 12:43 AM Rating: Decent
*
200 posts
I find they run better under FFXIV than the Current 266.58 Release.
____________________________


#3 Mar 02 2011 at 1:25 AM Rating: Good
With an evga gtx 470 and these new beta drivers I'm running at least 10 degrees cooler than with the 266.58. has anyone else noticed a similar drop in temps?
____________________________

Does hating a game I wanted to love make me a troll?
or does trying to love a game I hate make me a white knight?
#4 Mar 04 2011 at 6:05 PM Rating: Decent
13 posts
These driver have improved performance for my GTX570. Originally, I upgraded from an ATI4870 and using the 266.58, I was getting worse performance.

These beta drivers improved performance, however, the performance of FFXIV on these cards is nothing short of disappointing. I can completely max out the graphic settings on any other game I have and they run smoothly, but, I cant activate Ambient Occlusion on FFXIV or I get noticeable poor framerates. :(

On a different note, I get lag in specific areas while walking around. Always at the same points. This is hard disk loading I suspect. Anyone else have this? It is really **** annoying!!!

Edited, Mar 4th 2011 7:08pm by Drakenabarion
#5 Mar 04 2011 at 6:14 PM Rating: Good
Sage
**
551 posts
FelixValmont wrote:
I find they run better under FFXIV than the Current 266.58 Release.


Same here.
____________________________



This forum is read only
This Forum is Read Only!
Recent Visitors: 15 All times are in CST
Anonymous Guests (15)