Forum Settings
This Forum is Read Only

I'm desperate here.Follow

#1 Mar 25 2011 at 1:10 PM Rating: Default
4 posts
Alright, I don't know if this is the proper area to post things like this, but here goes. I was logging in fine before the earthquake and whatnot in Japan, and figured "No big deal, gaming isn't important right now" when they shut it down. When the servers came back online early this morning, I attempt to contain my excitement at logging in to my addiction once more. The problem, however, is that SE has locked me out of my account due to "suspicious activity." I go to reset my password and I assume everything is going to be sorted out, but that is not the case. After resetting it, I try to log in again, but it says the new password is incorrect. I tried my old password to see if something has gone wrong with the reset, just for it to tell me the same "suspicious activity" message.

I have reset my password four times, and it hasn't worked a single time. Any suggestion would be simply wonderful.
#2 Mar 25 2011 at 1:18 PM Rating: Default
186 posts
Wow. Same thing happened to me but I managed to log in after resetting my password...

I'll make sure this thread doesn't die out until we find the answer to the problem.
Watch who you are calling Douchebags, jerk. BANNED
#3 Mar 25 2011 at 1:54 PM Rating: Decent
4 posts
I guess I'm going to continue trying, but my persistence can only take me so far...
#4 Mar 25 2011 at 3:09 PM Rating: Good
812 posts
I think their security system is supposed to send you an email with instructions on what to do if you get locked out. If you don't have that email a call to SE tech support is probably in your future. I'd hurry too as they won't be open much longer today. If you can't get in today, and don't have that email, you'll be screwed 'til at least monday.
Abaddon Active Player Roster
- All your Fabul Sever are belong to us! -

#5 Mar 25 2011 at 4:21 PM Rating: Decent
4 posts
As it turns out, my friend who lives pretty close is having the same problem. It's good to know that it isn't just me having the problem. It looks to me like the password reset system is simply not doing anything at this point.
#6 Mar 25 2011 at 4:38 PM Rating: Decent
8 posts
Try Emailing tech Support or give em a call is your best bet with problems such as those
This forum is read only
This Forum is Read Only!
Recent Visitors: 5 All times are in CDT
Anonymous Guests (5)