Forum Settings
       
This Forum is Read Only

Culture ShockFollow

#1 Apr 27 2012 at 2:21 PM Rating: Good
*
107 posts
Is the quest Culture shock bugged? I just watched a video on youtube and at the end there should be 4 Merchants and I only see 2....I tried re-entering the instance and I've didn't see anything posted about it.
____________________________


#2 Apr 28 2012 at 5:24 PM Rating: Good
*
107 posts
Ok so I just decided to try and do some other quests and I am doing "Arms Race" quest now and I go talk to the 3 couriers to get the plans and Raaka Maaka isn't showing up...Maybe it has something to do with the that one race?
____________________________


#3 Apr 28 2012 at 6:27 PM Rating: Good
Sage
Avatar
**
676 posts
I'm not sure what the issue is. Perhaps its just lag keeping the NPC from showing up. It's not uncommon in areas such as uldah. Just in case you didn't know, you can go into your journal and click on the quest name. There you'll see a review of what you've done so far in the quest and there's a small "map" button. Click on that and it'll show you the location of where/who you need to go or talk to. If its a general location of something you need to kill, it'll be a big yellow circle. If its an NPC that you have to talk to, it'll show up a a small white circle with an "!" in the middle of it. If you ever have a question of where you need to go, just check the map and it'll point you in the right direction.

Just in the small chance you haven't seen this already. Here's a guide to the quest "Culture Shock" found on this website. It's not exactly detailed, but it'll get the job done.
____________________________
#4 Apr 28 2012 at 7:29 PM Rating: Good
*
107 posts
Ok for some reason the Lalafell aren't showing up on screen that's the name of the race...sorry if I offended anyone. I can't see them or target them and I had hoped to finish up this quest and be able to get my chocobo....guess I'll have to wait till 1.22a?
____________________________


#5 Apr 28 2012 at 7:35 PM Rating: Good
*
107 posts
Weird...maybe the servers are lagged out or something. I'm literally standing on the spot there the npc is supposed to be...maybe if i leave it on overnight and see what happens.
____________________________


#6 Apr 29 2012 at 11:35 AM Rating: Good
***
1,606 posts
This isn't helpful input but it reminds me of when Brutus wouldn't load when doing that chocobo quest. Was a day or two before he reappeared.

Hopefully you'll get it worked out ^^
#7 Apr 29 2012 at 12:13 PM Rating: Good
*
107 posts
ya maybe they server guys need to come in and fix something, maybe on monday they'll get it fixed.
____________________________


This forum is read only
This Forum is Read Only!
Recent Visitors: 16 All times are in CST
Anonymous Guests (16)