Forum Settings
       
This Forum is Read Only

I need help updating my ati control center version plz!Follow

#1 Jul 20 2012 at 10:27 AM Rating: Default
*
50 posts
so in order to play this game i need ati 10.8-9 (cant do it with the newest version 12.6 because the game will show a has stopped working problem).I restore my computer downloaded both 10.8-9 and dont see the version in the catalyst control center. (version wont appear and the year that appears at the end is 2009-10 need help plz! how to update it
#2 Jul 20 2012 at 10:44 AM Rating: Good
Avatar
***
3,112 posts
Weird, I run on 12.6 with no issues at all... But I do remember it was really hard to find specific versions of catalyst if you really needed to roll back to a specific driver.

Try here: http://support.amd.com/us/gpudownload/windows/10-8/Pages/radeonaiw_vista64.aspx?&lang=English though and see if that helps. This is the 64 bit version, but I am sure if you need others you can find it off this.
____________________________
95THF, 95DRG, 90BRD, 94BLM, 95BLU, 90COR - Retired: Nov 2011
Someday soon my friends, this ride will come to and end, and we can't just get in line again.
#3 Jul 20 2012 at 1:01 PM Rating: Default
*
50 posts
well for some reason i had 12.6 installed but when i try to install the game it says "has stopped working" idk why it says that when i have 12.6 ;/ if u could help me out? i have asus 5870
#4 Jul 20 2012 at 1:37 PM Rating: Decent
*
50 posts
look has you can see i have the 12.6 version but at the end i have the 2009 version and idk how i can actually update that
Driver Packaging Version 8.683-091217a-092929C
Catalyst™ Version 12.6
Provider ATI Technologies Inc.
2D Driver Version 8.01.01.984
2D Driver File Path /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000
Direct3D Version 8.14.10.0716
OpenGL Version 6.14.10.9236
Catalyst™ Control Center Version 2009.1217.1632.29627

see catalyst version 12.6 but at the end it says catalyst control center version 2009.1217 and my game wont install because of that. i need like the 2010.10 one i think.
if not i get this while trying to download "has stopped working". i have asus g73. ati radeon 5870.
i currently installed all updates and directx11 . if you know how to update that version i would appreaciated! im a fan of ff and i will do everything to download this game! :)
#5 Jul 20 2012 at 2:06 PM Rating: Good
Avatar
***
3,112 posts
It is hard to pinpoint what the exact issue would be. You could try completely uninstalling catalyst and removing the card in device manager and then rebooting and let windows install the recommended drivers for it and try again. I was running the game with a 5770 before and was using a 2009 driver with it, so it could be that the 5000 series cards just haven't received any driver updates since then.

When exactly do you see the "Has stopped working" message? Is it in game or just when you are trying to update/patch the game? If it is just during the patching, I would doubt it would be the graphics card or directx, but could maybe be a firewall/router issue.
____________________________
95THF, 95DRG, 90BRD, 94BLM, 95BLU, 90COR - Retired: Nov 2011
Someday soon my friends, this ride will come to and end, and we can't just get in line again.
#6 Jul 20 2012 at 4:38 PM Rating: Decent
*
50 posts
it happens when im downloading the game actually. i havent downloaded the game because it says "has stopped working issue" and cant fix it. ive tried everything and still wont ;/
#7 Jul 20 2012 at 4:40 PM Rating: Decent
*
50 posts
and about uninstalling driver. i did a system restore and went to amd and installed the latest/newest driver (12.6) so idk whats happening really ;/
#8 Jul 20 2012 at 7:48 PM Rating: Good
****
4,144 posts
bahamothz wrote:
and about uninstalling driver. i did a system restore and went to amd and installed the latest/newest driver (12.6) so idk whats happening really ;/


Download Driver Sweeper and use it to completely remove your previous ATI drivers. Then, if you haven't already downloaded them, download the official drivers and install them again.

Many times when you install drivers they don't completely remove everything from the previous version which can cause problems. System restore will not remove these files. You have to manually remove them and re-install.

*EDIT*

Please don't create 3 threads for the same problem. It's in your best interest and the interest of those trying to assist you to keep all of the information on what you have done to try and solve the problem in one neat, easy to follow thread.

-MGMT

Edited, Jul 20th 2012 9:56pm by FilthMcNasty
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
This forum is read only
This Forum is Read Only!
Recent Visitors: 16 All times are in CST
Anonymous Guests (16)