Forum Settings
       
Reply To Thread

Do we need to download new client for p4? Follow

#1 Aug 16 2013 at 6:22 AM Rating: Default
*
219 posts
i am not sure if server are up now but i am keep getting unable to complete version check.
#2 Aug 16 2013 at 6:24 AM Rating: Decent
Scholar
Avatar
**
304 posts
Yes, you need to download a new version of the launcher and redownload the game once more from it. Look for it in the beta forums, should be where the old one was.

Or look for your beta email there should be a link there aswell.

Edited, Aug 16th 2013 8:24am by Manikku
____________________________
WoW:
Tsunamoo, Level 80 Tauren Druid on Tichondrius
*Insert other 5 80's here* -NOT IMPORTANT- ^ MAIN
-------
FFXIV:
Jin Lagun, @ Bodhum

#3 Aug 16 2013 at 6:25 AM Rating: Default
*
219 posts
can i have a link to it?
seriously, i can't find a link to it anywhere because i can't open the old client anymore.

Nevermind, how can i forgot about the almighty google.

Edited, Aug 16th 2013 8:27am by wrongfeifong
#4 Aug 16 2013 at 6:42 AM Rating: Decent
Scholar
Avatar
**
304 posts
Sorry, would've posted one but I didnt have one at hand (is at work) xD but glad you found it.
____________________________
WoW:
Tsunamoo, Level 80 Tauren Druid on Tichondrius
*Insert other 5 80's here* -NOT IMPORTANT- ^ MAIN
-------
FFXIV:
Jin Lagun, @ Bodhum

#5 Aug 16 2013 at 7:08 AM Rating: Excellent
Avatar
**
311 posts
http://lodestone.finalfantasyxiv.com/pl/news/detail?newsId=5619b4001c16ec3b02e1eb8b06e5881a6f57c992

There you go.
____________________________
FFXIV: Raxion Gunsoul - Brynhildr - 50PLD 50SMN 50SCH 50DRG
WoW: Raxion - Greymane- 90 Druid
FFXI: Nion - Asura - 99 BLU, PUP, SMN, DRG, PLD 50+ DNC, NIN, MNK, THF, WHM, SAM, WAR
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 73 All times are in CST
Anonymous Guests (73)