Forum Settings
       
Reply To Thread

how do i make my ffxiv active?Follow

#1 Aug 26 2013 at 11:04 PM Rating: Decent
33 posts
i have a 1.0 code but when i go to put in my code it says that it is already registered but says inactive... how can i change that? i have no idea how to make it active
#2 Aug 27 2013 at 2:52 AM Rating: Decent
Avatar
*
138 posts
My guess would be you are logged into a wrong account you aren't logging into your old 1.0 account? If you are I would contact SE about this and find out what's going on.. That's all you can I'm afraid.. First make sure you have logged into the right account first, may sound stupid, but we all make mistakes.
#3 Aug 27 2013 at 3:15 AM Rating: Decent
33 posts
Omniworm wrote:
My guess would be you are logged into a wrong account you aren't logging into your old 1.0 account? If you are I would contact SE about this and find out what's going on.. That's all you can I'm afraid.. First make sure you have logged into the right account first, may sound stupid, but we all make mistakes.


i appreciate the reply, i logged into the right account its my ffxi account which i added xiv when it was released, now it just says my account is inactive and when i try to log into the game it says that i don't have a service account to log in with but when i try to put my code in it already says the code has already been registered.... i really don't understand why this has to be so difficult, i'm amazed at the fact that it can never be simple with SE... even dealing with customer support already has me giving up mentally
#4 Aug 27 2013 at 3:18 AM Rating: Decent
Scholar
Avatar
**
599 posts
If you go to the SE account management page, you can confirm account status through one of the links on the side. You can activate it somewhere here.
#5 Aug 27 2013 at 3:22 AM Rating: Decent
33 posts
Adzieboy wrote:
If you go to the SE account management page, you can confirm account status through one of the links on the side. You can activate it somewhere here.


when i click confirm account status, then see what is registered it shows ffxiv is registered but when i go to mog station it shows the account status to be inactive and i don't understand that
#6 Aug 27 2013 at 3:32 AM Rating: Decent
****
4,134 posts
ThadCastleBMS wrote:
Adzieboy wrote:
If you go to the SE account management page, you can confirm account status through one of the links on the side. You can activate it somewhere here.


when i click confirm account status, then see what is registered it shows ffxiv is registered but when i go to mog station it shows the account status to be inactive and i don't understand that

I don't think anyone is going to be able to help you out with this. Either there is something on SE's side blocking your account from being active, or you're using an account that you just created and not logging in to the old account you created during 1.0 version. I know it sucks to not be able to play, but SE support center is probably your only way to get the issue cleared up.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#7 Aug 27 2013 at 3:41 AM Rating: Decent
33 posts
FilthMcNasty wrote:
ThadCastleBMS wrote:
Adzieboy wrote:
If you go to the SE account management page, you can confirm account status through one of the links on the side. You can activate it somewhere here.


when i click confirm account status, then see what is registered it shows ffxiv is registered but when i go to mog station it shows the account status to be inactive and i don't understand that

I don't think anyone is going to be able to help you out with this. Either there is something on SE's side blocking your account from being active, or you're using an account that you just created and not logging in to the old account you created during 1.0 version. I know it sucks to not be able to play, but SE support center is probably your only way to get the issue cleared up.



I registered my FFXIV Beta on the same account that has both my FFXI service and my FFXIV 1.0 which shows registered on "FINAL FANTASY XIV Registered: Sep. 2, 2010".

When I start up the launcher and put in my info it says I have no active account. I click the link to go to the mog station and it says "FFXIV: A Realm Reborn - Beta Test Windows(R) is registered to this service account." and says I am inactive.

what it means i believe is that they are not accepting my 1.0 code
#8 Aug 27 2013 at 3:51 AM Rating: Decent
****
4,134 posts
ThadCastleBMS wrote:
I registered my FFXIV Beta on the same account that has both my FFXI service and my FFXIV 1.0 which shows registered on "FINAL FANTASY XIV Registered: Sep. 2, 2010"

what it means i believe is that they are not accepting my 1.0 code


If you can see FFXIV registered to your account, that means your code was accepted the first time you registered it 3 years ago. There is no need to register it a second time. Your account should automatically be granted access up to September 9th, but that hasn't happened for you for some reason. You're going to need a customer service rep to help you with that.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#9 Aug 27 2013 at 3:56 AM Rating: Decent
33 posts
FilthMcNasty wrote:
ThadCastleBMS wrote:
I registered my FFXIV Beta on the same account that has both my FFXI service and my FFXIV 1.0 which shows registered on "FINAL FANTASY XIV Registered: Sep. 2, 2010"

what it means i believe is that they are not accepting my 1.0 code


If you can see FFXIV registered to your account, that means your code was accepted the first time you registered it 3 years ago. There is no need to register it a second time. Your account should automatically be granted access up to September 9th, but that hasn't happened for you for some reason. You're going to need a customer service rep to help you with that.


yeah unfortunately i accept that now lol, i appreciate the responses.
#10 Aug 27 2013 at 3:58 AM Rating: Decent
****
4,134 posts
Sorry man, I know it sucks to wait. If you can, try and contact support as soon as you can later today when they open. They are going to be incredibly busy on launch day so be prepared for a long wait Smiley: frown
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#11 Aug 27 2013 at 4:01 AM Rating: Decent
33 posts
FilthMcNasty wrote:
Sorry man, I know it sucks to wait. If you can, try and contact support as soon as you can later today when they open. They are going to be incredibly busy on launch day so be prepared for a long wait Smiley: frown


to be honest im gonna try later on today after work, if i don't get through or its just a bigger headache i'd consider picking up a new copy but my principles wouldn't allow it lol. i'd just move on to another game
#12 Aug 27 2013 at 4:56 AM Rating: Good
**
749 posts
For the record you're not the only one. In addition, it's only listing my registration as a beta registration. . Yet I still have access to my Garlond Goggles from my retail purchsae? Even funnier, in the account management page where it lists my registration as "beta" it lists those goggles as a registered bonus item.

____________________________
http://www.rantmedia.ca/newsreal/
http://www.piratepartyradio.com


The Truth is a virus
#13 Aug 27 2013 at 10:58 AM Rating: Decent
I was on hold for 3 hours yesterday and I dont want to call them back. I hope you guys can help me. I bought FFXIV CE in 2010, I played the free trial from the game but never payed for service. I played Beta for a while. Since I own FFXIV 1.0 I understand I should not have to purchase FFXIV ARR.
I went to https://secure.square-enix.com/account/app/svc/ffxivshopacctop after I got this error message: No valid or active service account is available to play FINAL FANTASY XIV: A Realm Reborn from the launcher, this morning 8/27/2013. I go to the website to register my FFXIV, it says it is already registered. I redownloaded the game client from http://www.finalfantasyxiv.com/playersdownload/na/ I get the same error message from the launcher.
____________________________
Although with ill intention one man raised up an army, motivated a nation and waged war on the world. It is sad that Hitler could not use this energy for good, but this shows what one man can do with a lifetime. NOW BOYS AND GIRLS waste away your life on FFXI with me? Maat's Cap FTW!
#14 Aug 27 2013 at 11:24 AM Rating: Decent
33 posts
TerriCerberus wrote:
I was on hold for 3 hours yesterday and I dont want to call them back. I hope you guys can help me. I bought FFXIV CE in 2010, I played the free trial from the game but never payed for service. I played Beta for a while. Since I own FFXIV 1.0 I understand I should not have to purchase FFXIV ARR.
I went to https://secure.square-enix.com/account/app/svc/ffxivshopacctop after I got this error message: No valid or active service account is available to play FINAL FANTASY XIV: A Realm Reborn from the launcher, this morning 8/27/2013. I go to the website to register my FFXIV, it says it is already registered. I redownloaded the game client from http://www.finalfantasyxiv.com/playersdownload/na/ I get the same error message from the launcher.


I'm having the same issue, it seems like the codes aren't working for a realm reborn to be honest, I tried customer service but can't get through, I'm getting really annoyed
#15 Aug 27 2013 at 11:24 PM Rating: Decent
2 posts
I am having the SAME ISSUE! I made a ZAM account just to respond to this thread. My friend and I are experiencing the SAME EXACT PROBLEM. Its like the Mog Station and the SE Account Management are not communicating or linking well. Says I have beta but not an actual game. Account Type: None.... So i emailed SE support team and I hope they fix it. If they dont within 24 hours I cannot play this game. It ruined my taste of Final Fantasy once before. That plus my characters names are all saved on that account and buying a new copy just for the registration code will not do....
#16 Aug 27 2013 at 11:38 PM Rating: Decent
****
4,134 posts
Do me a favor if you can. Log in to your Mog Station, click the top left button called 'Account Services' and take a screenshot. Open it in a program like paint if you need to remove any personal or character information, but I'm trying to get an idea of what you guys see when you are logging in.

There are a lot of reports of people who get different things and it will help if I can compare yours to what they're supposed to look like. I'm thinking there is just a bug that isn't allowing you to reactivate. I remember this being an option through the old Square Enix ID system, but every time I try to access that through the old website it always redirects.

Try and upload screenshots for me, otherwise it's a simple, but long wait call to Square Enix customer support center to have your account reactivated.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#17 Aug 28 2013 at 10:17 AM Rating: Decent
1 post
Hello,

I'm facing the same problem and opened a ticket on support yesterday. I only got the automatic reply 24 hours later, so I guess I still have some time before a real answer.
Anyway here is how it looks like :

http://img834.imageshack.us/img834/8121/udvd.png

This is in French language, sorry, but this can give you an idea.

Trying to add a service prompts for a registration code, and trying to put the 1.0 activation code results in an error message stating that it has already been used.
#18 Aug 28 2013 at 12:36 PM Rating: Decent
2 posts
Vanen thats exactly what I see on mine. Aucun means NONE in English. So basically account type is: NONE. and Inactif means INACTIVE.
The crazy thing is that this morning when I wake up and try to login to the launcher, instead of telling me to go to the mog station to activate service account, it directs me to "do you possess a SE account or do you want to create a new account name". Which is CRAZY because when I click on "I posess an SE account" it directs me to a page where I HAVE TO INPUT A REGISTRATION CODE. This is insane! I put in my old collectors edition code and it says its already been in use, WELL NO DUH.
The strange thing is too that my Square Enix Account Management shows that in my Service History that I registered FFXIV back in Sept.2010 but the Mog Station shows I do not own it but that I was in the beta.... Which is why the game keeps acting like I dont own the dang game.... This is gonna kill me as a SE fan....
#19 Aug 28 2013 at 3:18 PM Rating: Decent
****
4,134 posts
I think there is a problem with the Mog Station website itself and not the actual account. From what I've been able to find, there is supposed to be a button there to reactivate your account. This used to be something you could do through the Square Enix ID page, but whenever you try to access that and select FFXIV as your service, it automatically redirects you to Mog Station.

The only fix for now is to contact Square Enix Support Center and have them activate the account for you Smiley: frown
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#20 Aug 28 2013 at 3:49 PM Rating: Decent
Scholar
***
1,652 posts
Yea SE support wont get back too you for a long time right now. Took them almost 3 days to even send me a email saying that they will get back too me in a few days.

Again more stuff that should have been ironed out and tested before launch...

Edited, Aug 28th 2013 5:50pm by Nashred
____________________________
FFXI: Nashred
Server: Phoenix

FFXIV : Sir Nashred
server: Ultros
#21 Aug 28 2013 at 4:04 PM Rating: Decent
Scholar
Avatar
**
560 posts
Ive been on the fence about rejoining the game(I have 2 CE's from 2010) with all the nightmares im reading I guess I will just wait for a bit to try.

I dont have any idea why SE has to be so convoluted about signing up to play. I mean if I were to make a game I would make the barrier to entry as small as possible. Seems like the same ole SE. Really a big turn off. I may need to just stick to US companies because SE isnt very NA friendly.
____________________________


#22 Aug 28 2013 at 4:10 PM Rating: Decent
****
4,134 posts
Nashred wrote:
Yea SE support wont get back too you for a long time right now. Took them almost 3 days to even send me a email saying that they will get back too me in a few days.

Again more stuff that should have been ironed out and tested before launch...


You need to actually speak to them when you contact them. If you're going through the website then select an option like resetting password. You can fill out the correct issue in the details box, but unless you pick something considered higher tier they'll just give you the email form. What you want is phone or chat session.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#23 Aug 30 2013 at 12:18 PM Rating: Decent
1 post
I hope this link helps you. It helped with my problem!

https://pay.reddit.com/r/ffxiv/comments/1le7gb/if_youre_being_asked_to_enter_your/
#24 Aug 30 2013 at 12:30 PM Rating: Decent
2 posts
Hello

I have similar issue. I was able to play the early acess and I havnt been able to play till late last night.

Today I tried to log in and I have this issue.

I'm pretty sure no one will be able to help me but I will like to know if the original poster (and another one) was able to fix the problem.

Images below

First image is my status and the second is when I try to use my key (I already used it before for the account)


[img]http://s14.postimg.org/ushc3mwxd/image.png[/img]
[img]http://s10.postimg.org/6538lbppl/image.png[/img]
#25 Aug 30 2013 at 12:40 PM Rating: Decent
****
4,134 posts
You need to contact SE customer support(either over the phone or through chat) and have them activate your account.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#26 Aug 30 2013 at 1:26 PM Rating: Decent
Scholar
*
237 posts
I'm in the same boat, I have an early access registration code. It now wants me to put in the reg code again, but says it's already been registered. This is so frustrating, there is no clear cut answer to be found on the support page. Plus trying to navigate SE pages is like walking through a labyrinth.
#27 Aug 30 2013 at 1:31 PM Rating: Decent
****
4,134 posts
crazyorc wrote:
I'm in the same boat, I have an early access registration code. It now wants me to put in the reg code again, but says it's already been registered. This is so frustrating, there is no clear cut answer to be found on the support page. Plus trying to navigate SE pages is like walking through a labyrinth.


That's why I put up a (somewhat) organized sticky. Nobody reads it Smiley: glare

There are two different codes. One of them is for early access. This creates a service account that was active from Sept 24 through Sept 29.

The second code is the actual game registration. This updates the service account you created with the early access code and makes it a fully registered account with no restrictions. Once you actually register the game you get the 30 day trial period and after that you start paying.

You don't have enough information here. We would need to know where you got the game if it's a digital download. Also, depending on if it's PC or PS3 version there are different processes for registering. Check the sticky and see if it helps. If not, come back and post more info.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#28 Aug 30 2013 at 1:40 PM Rating: Default
*
212 posts
FilthMcNasty wrote:
You need to contact SE customer support(either over the phone or through chat) and have them activate your account.


Funniest thing I've seen in months..

Phone lines are perma busy and chat options have been removed.

Your "customer support" option is submit an email ticket and then go F yourself...



____________________________
MUTED - 24 Hour
#29 Aug 30 2013 at 2:03 PM Rating: Decent
Scholar
*
237 posts
FilthMcNasty wrote:
crazyorc wrote:
I'm in the same boat, I have an early access registration code. It now wants me to put in the reg code again, but says it's already been registered. This is so frustrating, there is no clear cut answer to be found on the support page. Plus trying to navigate SE pages is like walking through a labyrinth.


That's why I put up a (somewhat) organized sticky. Nobody reads it Smiley: glare

There are two different codes. One of them is for early access. This creates a service account that was active from Sept 24 through Sept 29.

The second code is the actual game registration. This updates the service account you created with the early access code and makes it a fully registered account with no restrictions. Once you actually register the game you get the 30 day trial period and after that you start paying.

You don't have enough information here. We would need to know where you got the game if it's a digital download. Also, depending on if it's PC or PS3 version there are different processes for registering. Check the sticky and see if it helps. If not, come back and post more info.


Where is the second code located I still haven't been able to find it, also thanks I missed the sticky!
#30 Aug 30 2013 at 2:57 PM Rating: Decent
****
4,134 posts
One code is on the booklet itself and the other inside the leaflet.
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#31 Aug 30 2013 at 3:49 PM Rating: Decent
Scholar
*
237 posts
Sorry doesn't help those who digital downloaded.
#32 Aug 30 2013 at 7:15 PM Rating: Good
Scholar
*
130 posts
I had this happen to me earlier today. If you bought the digital download from SE there is a 2nd code you need to find and enter. The code SE emails you only gives you early access. To get the second code go to store.na.square-enix.com/orders and enter your order info. Hopefully this saves people from the frustration I had this morning!
____________________________
75 THF, 75 SAM, 75 NIN, 75 BLM, 75 BRD, 73 SMN, 72 RNG, 70 COR
Sylph

#33 Aug 30 2013 at 7:22 PM Rating: Decent
Scholar
18 posts
I am trying to input my code in on the ps3 account management redeem codes the website and mog station are not working at all
#34 Aug 30 2013 at 10:11 PM Rating: Decent
2 posts
Arkan24 wrote:
Hello

I have similar issue. I was able to play the early acess and I havnt been able to play till late last night.

Today I tried to log in and I have this issue.

I'm pretty sure no one will be able to help me but I will like to know if the original poster (and another one) was able to fix the problem.

Images below

First image is my status and the second is when I try to use my key (I already used it before for the account)


[img]http://s14.postimg.org/ushc3mwxd/image.png[/img]
[img]http://s10.postimg.org/6538lbppl/image.png[/img]


FilthMcNasty wrote:
You need to contact SE customer support(either over the phone or through chat) and have them activate your account.





For some reason I had to go to
www.findmyorder.com and look at my order. Then my "key" changed. I never receive any e-mail or got contacted about it. In other word, they give me a code how doesnt work then they change it without telling me

Game is fun but everything else is ****
#35 Aug 31 2013 at 11:04 AM Rating: Decent
1 post
This worked perfectly for me. Created an account here on ZAM just to say that it worked, and thank you all for posting on the interwebs and helping us get through the whirlwind tornado **** storm of a mess that is SE's login pages. THANK YOU!
#36 Aug 31 2013 at 11:27 AM Rating: Decent
33 posts
Hey all, so I been trying to contact support since the start, all phone lines are busy non stop I kinda believe its on purpose, chat support doesn't exist only email support, I sent 4 emails with diff priorities too see when they will get back to me and only got two so far saying they will contact me in a few days, I personally have no will to play the game anymore, in my gut it feels like 1.0 and I just don't really care to play it. Good luck to you guys still trying hopefully it can work soon.
#37 Aug 31 2013 at 4:21 PM Rating: Decent
FilthMcNasty wrote:
crazyorc wrote:
I'm in the same boat, I have an early access registration code. It now wants me to put in the reg code again, but says it's already been registered. This is so frustrating, there is no clear cut answer to be found on the support page. Plus trying to navigate SE pages is like walking through a labyrinth.


That's why I put up a (somewhat) organized sticky. Nobody reads it Smiley: glare

There are two different codes. One of them is for early access. This creates a service account that was active from Sept 24 through Sept 29.

The second code is the actual game registration. This updates the service account you created with the early access code and makes it a fully registered account with no restrictions. Once you actually register the game you get the 30 day trial period and after that you start paying.

You don't have enough information here. We would need to know where you got the game if it's a digital download. Also, depending on if it's PC or PS3 version there are different processes for registering. Check the sticky and see if it helps. If not, come back and post more info.


Which I did but for some reason it created another service account and i no longer have access to my characters. I have just got my archer to level 30 and lvl 15 so i could unlock my bard-_- don't want to recreate
#38 Aug 31 2013 at 4:36 PM Rating: Decent
found this

If you registered your FINAL FANTASY XIV: A REALM REBORN registration code or product code to the wrong service account, we will confirm your identity first and analyze your situation to determine if support is possible.

If you would like to request assistance, please follow these steps.

(1) Click the below URL
   URL:https://support.na.square-enix.com/contact.php?id=5382&la=1&daxx=2
(2) The "Terms of Service" and "Contact Detail Entry Fields" will be displayed. Fill out all required fields and click "Next"
(3) Confirm that the details were entered correctly and click "Send"
*If you registered your registration code to the wrong Square Enix ID, please click here.
*For more information on service accounts, see the below link.
http://support.na.square-enix.com/faqarticle.php?id=496&la=1&kid=12822&ret=faqtop&c=4&sc=0
*This recovery can only be performed once per account.
#39 Aug 31 2013 at 5:20 PM Rating: Decent
Scholar
***
1,652 posts
FilthMcNasty wrote:
Nashred wrote:
Yea SE support wont get back too you for a long time right now. Took them almost 3 days to even send me a email saying that they will get back too me in a few days.

Again more stuff that should have been ironed out and tested before launch...


You need to actually speak to them when you contact them. If you're going through the website then select an option like resetting password. You can fill out the correct issue in the details box, but unless you pick something considered higher tier they'll just give you the email form. What you want is phone or chat session.



Yea the wait times were 3 hours for that the last time I looked.
____________________________
FFXI: Nashred
Server: Phoenix

FFXIV : Sir Nashred
server: Ultros
#40 Sep 02 2013 at 5:44 PM Rating: Decent
2 posts
Hey i hope this helps because i was having the same issue. its actually version one that your trying to enter your code into if u look at the middle of the screen you will see a yellow tab that has the number "2" on it. That is where u reactivate your account. At the bottom of the page will say something like reactive service account. Just by clicking that i was able to log in with the client i downloaded off the arr site. Hope this helps because i couldnt find any info on this problem.
#41 Sep 02 2013 at 5:45 PM Rating: Decent
2 posts
Edit: the screen i am refering to is the mog station of course.
#42 Sep 05 2013 at 3:00 PM Rating: Decent
1 post
I am having the exact same issue. Where are you guys finding the site that has SE's phone number on it because I am having trouble finding it. All I have been able to find is their email/chat support in which I seem to be getting completely ignored via email and have been kicked out of chat after waiting 2-4 hours and within 5 in queue with the ever present "There are no agents to help you at this time" BS. Smiley: glare Have there been any new developments since the last post?

Edited, Sep 5th 2013 5:04pm by warspike
#43 Sep 06 2013 at 4:12 AM Rating: Decent
1 post
In your mind what is a GPS jammer and what can it do to help you? Only when you are in the situation that the GPS jammer is need you will understand how important and useful such kind of device is. Gaining more knowledge of the device? Just start and then you will have access to the best GPS jammer.


Edited, Sep 10th 2013 12:04am by MableSoffer
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 83 All times are in CDT
Anonymous Guests (83)