Forum Settings
       
Reply To Thread

New computer, no sound on TV from HDMI. Please help.Follow

#1 Oct 05 2013 at 1:47 AM Rating: Good
2 posts
I have recently purchased a alienware laptop and was really excited to play lag free ffxiv until i hooked it up to my tv and there were no sound.
My computer is hooked to my TV with HDMI and works perfectly with everything else. It has sound when i play the game on window mode but when its on full screen mode, the computer chimes and the sound goes completely out. Have been fidling around with it in control panel and no luck... any computer experts have any ide whats happenin?
#2 Oct 05 2013 at 4:10 AM Rating: Excellent
***
1,112 posts
Do get the same behaviour from the onboard speakers too?
____________________________
To endanger the soul endangers all,
when the soul is endangered it must become a Warrior.
#3 Oct 05 2013 at 4:12 AM Rating: Excellent
Avatar
**
283 posts
Depending on your OS (I assume windows 7-8) you would go to your sound settings and indicate the hdmi/tv monitor as destination. It's probably on mute.
____________________________


#4 Oct 05 2013 at 5:00 AM Rating: Good
**
438 posts
So let's get something clear.

You have sound on your TV when playing in windowed mode, but the sound cuts out if you play full screen?

What about Windowed (fullscreen)?

Is your TV set as the default sound program?
____________________________
Star Swirl on Behemoth AKA Best-hemoth AKA The Cool Kid's Table----60AST, 60WHM, 60SCH/SMN, 60BLM, 60MNK, 38 PLD, 34DRG, 31NIN, 27MRD
FFXI- Derpypony on Asura
Check out the Dream Network, a Twitch.tv community for XIV fans, featuring notable streamers like Mr. Happy, MTQcapture, Rahhzay, and Slyakagreyfox! http://dreamnetwork.tv/forum/index.php
Then maybe check out myself, EquestriaGuy, on twitch at http://www.twitch.tv/equestriaguy


#5 Oct 05 2013 at 5:33 AM Rating: Good
****
4,151 posts
A few things you could try:

1) Get an 1/8 to RCA adapter and run the 1/8 out of the audio jack on your laptop and into the audio in on your TV...

2) Click the start button > click 'Control Panel' > click 'Hardware and Sound' > click 'Sound' > Mouse-over your HDMI device, right click it and select 'Enable'

You can also select 'Set as Default Device' if it's mainly what you're using your laptop for. You may or may not need to reconnect the cable after doing this.

2 & 1/2) You could try going into the game configuration under sound settings and check the box that allows you to play sound in the background

3) Play with a **** pair of wireless headphones



Edited, Oct 5th 2013 8:37am by FilthMcNasty
____________________________
Rinsui wrote:
Only hips + boobs all day and hips + boobs all over my icecream

HaibaneRenmei wrote:
30 bucks is almost free

cocodojo wrote:
Its personal preference and all, but yes we need to educate WoW players that this is OUR game, these are Characters and not Toons. Time to beat that into them one at a time.
#6 Oct 05 2013 at 6:24 AM Rating: Good
Check what is the default playback device when you are in full screen or windowed.
You may need to reconfigure the audio devices and set them as the default source.
This has happened to me where the audio under a full screen game would stop and playback from another audio device (headphones) instead of my computer speakers.

Just in case you need instructions:
I'll assume you are on Windows 7 since that is the current OS I'm using.
Go to the Control Panel and click on "Hardware and Sound", then click "Sound" or "Manage audio devices" to bring up the Sound properties window. Alternatively you can right click on your Speakers icon usually located to the bottom right on your Taskbar.

With the Sound window up you should see a list of audio devices under the Playback tab.
Right click on each audio device and choose Test. This will send a simple audio test to determine if you can hear the audio playback on the device.
Here now you can know what device is properly playing back your sound and choose your default audio device (default device marked with a green check) for all your sound playback.

If above fails lets test it with FFXIV:
With the Sound window open, start FFXIV in windowed mode and look at what is the default device.
- Don't know if this next part works since i only play in windowed mode.
Now with the Sound window open, start FFXIV in full screen and tab out and look at the Sound window to see which device the game in full screen is using.

Only thing left i can think of is if all that fails then disable all the unused audio devices and set 1 as the default device for all.

Good Luck.
____________________________
One day maybe:
ShaolinGate.com
#7 Oct 05 2013 at 10:30 AM Rating: Good
2 posts
Thank you guys for the replys. I tried all but still a no go haha maybe it needs fixin... A brand new computer that needs fixin... not good haha for some reason everytime ffxiv is starting the laptop chimes and then when i get out of it, tje same sound happens on the tv...
#8 Oct 05 2013 at 3:26 PM Rating: Excellent
Needs More Smut
******
21,262 posts
There was an issue with older nVidia cards with sound from DVI to HDMI not functioning properly. However, that bug should be irrelevant now since your laptop ought to have native HDMI out.

Go into your video card's control panel (Catalyst for Radeon, forgot what it is for nVidia) and verify that it doesn't have full screen sound sent to go someplace where there.
____________________________
FFXI: Catwho on Bismarck: Retired December 2014
Thayos wrote:
I can't understand anyone who skips the cutscenes of a Final Fantasy game. That's like going to Texas and not getting barbecue.

FFXIV: Katarh Mest and Taprara Rara on Lamia Server - Member of The Swarm
Curator of the XIV Wallpapers Tumblr and the XIV Fashion Tumblr
#9 Oct 05 2013 at 4:01 PM Rating: Excellent
Avatar
7 posts
Had the same trouble with my Alienware when connecting it to the TV. Please tell me if this works for you too:

1. Restart your computer.

2. At the Alienware Logo Screen press <F2>.

3. At the BIOS Setup Utility, use the <Right> arrow key and navigate to the “Advanced” tab.

4. Use the <Down> arrow key to highlight On-board High Definition Audio and press <Enter>.

5. Select “Enabled”.

6. Press <F10> to save changes and exit.

Edited, Oct 5th 2013 6:02pm by ImBackZAM
____________________________
Ultros: Va'lah Dreadnought

This tank likes to nerd-aggro on the forums. Tomahawk--GO!
#10 Oct 06 2013 at 12:25 AM Rating: Excellent
***
1,112 posts
You really need to test other things to see what is what easily. As I asked before, do you get the same no sound issues with onboard speakers or is it only when you run maximised via HDMI? Do other applications running full screen also not work with sound, or is it just XIV?
____________________________
To endanger the soul endangers all,
when the soul is endangered it must become a Warrior.
#11 Oct 06 2013 at 1:32 AM Rating: Excellent
Guru
Avatar
*****
11,082 posts
Catwho wrote:
There was an issue with older nVidia cards with sound from DVI to HDMI not functioning properly. However, that bug should be irrelevant now since your laptop ought to have native HDMI out.

Was under the impression DVI was simply HDMI's video signal algorithms without the audio. o.O
____________________________
Violence good. **** bad. Yay America.
#12 Oct 06 2013 at 5:53 AM Rating: Excellent
***
1,112 posts
Seriha wrote:

Was under the impression DVI was simply HDMI's video signal algorithms without the audio. o.O


Nah, bit more to it than that. HDMI does what DVI does plus more (it being the newer of the two) including transmission of audio packets as you mentioned, but also supports a better range of colour palleting. DVI only does RGB, HDMI does RGB and CbCr. HDMI also supports stuff like DTS encryption, and can transmit CEC commands so you can chain up decoders/players and they'll line up automatically on use.
____________________________
To endanger the soul endangers all,
when the soul is endangered it must become a Warrior.
#13 Oct 06 2013 at 7:19 AM Rating: Excellent
Needs More Smut
******
21,262 posts
Seriha wrote:
Catwho wrote:
There was an issue with older nVidia cards with sound from DVI to HDMI not functioning properly. However, that bug should be irrelevant now since your laptop ought to have native HDMI out.

Was under the impression DVI was simply HDMI's video signal algorithms without the audio. o.O


It was a bug specific to nVidia cards without audio chips. You could get a DVI to HDMI conversion cable or one of the dongle converters and run out an HDMI signal from the card, but the driver for nVidia would detect that it was connected to HDMI and completely override the onboard sound or existing sound card, because it assumed it controlled the audio stream as well.

nVidia never did come up with a solution - home grown workarounds included hacking and reprogramming the driver on the fly, or the solution I ultimately did, which was saying ***** it and buying a new cheap card with proper HDMI out. Smiley: glare
____________________________
FFXI: Catwho on Bismarck: Retired December 2014
Thayos wrote:
I can't understand anyone who skips the cutscenes of a Final Fantasy game. That's like going to Texas and not getting barbecue.

FFXIV: Katarh Mest and Taprara Rara on Lamia Server - Member of The Swarm
Curator of the XIV Wallpapers Tumblr and the XIV Fashion Tumblr
#14 Oct 06 2013 at 4:48 PM Rating: Excellent
Guru
Avatar
*****
11,082 posts
Catwho wrote:
Seriha wrote:
Catwho wrote:
There was an issue with older nVidia cards with sound from DVI to HDMI not functioning properly. However, that bug should be irrelevant now since your laptop ought to have native HDMI out.

Was under the impression DVI was simply HDMI's video signal algorithms without the audio. o.O


It was a bug specific to nVidia cards without audio chips. You could get a DVI to HDMI conversion cable or one of the dongle converters and run out an HDMI signal from the card, but the driver for nVidia would detect that it was connected to HDMI and completely override the onboard sound or existing sound card, because it assumed it controlled the audio stream as well.

nVidia never did come up with a solution - home grown workarounds included hacking and reprogramming the driver on the fly, or the solution I ultimately did, which was saying ***** it and buying a new cheap card with proper HDMI out. Smiley: glare

Just had me curious. I'm running on an old GTX285 with 2 DVI outs (and an S-Video, but no longer have a TV with that). I got a DVI > HDMI adapter so I could feed video to my TV again, but like this audio isn't an option. If there was some way I could fix that, great, but for now I've just been settling for audio from PC speakers.
____________________________
Violence good. **** bad. Yay America.
#15 Oct 07 2013 at 4:28 AM Rating: Good
Scholar
***
1,098 posts
I ran into the DVi-HDMi adapter problem a few years ago on my older video card in my 2nd computer you'll find maybe a few words searching about it online. The only solution I found is the 1/8 audio line output from the computer to the input of the monitor or TV....She gave a great technical explanation to something that tech support didn't know back then.
____________________________





#16 Oct 07 2013 at 5:39 AM Rating: Excellent
Guru
Avatar
*****
11,082 posts
Yeah, prior to my new TV I ran from the s-video line and split my speaker audio to that TV via RCA cables. I simply don't think that's possible like this unless I got some kind of switcher or amplifier to unify the signals into one feed. Granted I could probably find an s-video to RCA adapter, but being perfectly honestly, if I'm watching stuff on my TV from my PC, quality isn't my concern... so speaker audio suffices. It'll just be something to remember next time I upgrade to a new PC.
____________________________
Violence good. **** bad. Yay America.
#17 Oct 07 2013 at 8:03 AM Rating: Good
***
1,004 posts
I had several issues with HDMI on a laptop in the past, where audio would work until the laptop went to "sleep", and then resume functionality only after a reboot.

The issue would also occur if hdmi lost connection with the tv for any reason (I.E. it came unplugged, or someone flipped the light switch that controlled our entertainment system cutting off power).

Anyhow, my fix was related to the ATI/AMD drivers in windows 7, the trick was to go into the audio options in windows 7 where you would select the default playback device, choose the HDMI sound device (provided you can get it to show up in the first place, may require a hard reboot), view it's properties, and uninstall the driver from there. After uninstalling / rolling back the driver a couple times, it rolled all the way back to the default / generic / non ATI/AMD windows HDMI audio driver. This driver has worked flawless for over two years now. Not sure if this is your issue or not, but it's something to try as a last resort.
____________________________
Posting from just above the generator.
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 69 All times are in CST
Callinon, Larth, lolgaxe, Thayos, Xsarus, Anonymous Guests (64)